Bug 499398 - blkiomon prints nothing when blktrace works with logical volume
blkiomon prints nothing when blktrace works with logical volume
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: blktrace (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Edward Shishkin
BaseOS QE
:
Depends On:
Blocks: 650243
  Show dependency treegraph
 
Reported: 2009-05-06 10:32 EDT by Milos Malik
Modified: 2016-06-06 09:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 650243 (view as bug list)
Environment:
Last Closed: 2014-06-02 09:22:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2009-05-06 10:32:58 EDT
Description of problem:
Is it possible that blkiomon does not understand the output of blktrace when working with logical volume device? If I replace logical volume device with physical device, blkiomon prints I/O statistics as expected.

Version-Release number of selected component (if applicable):
blktrace-1.0.0-4.el5

How reproducible:
always

Steps to Reproduce:
# df -l
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      30503744   2401924  26527320   9% /
/dev/sda1               102182      9510     92672  10% /boot/efi
tmpfs                   990720         0    990720   0% /dev/shm
# blktrace -w 30 -o physical -d /dev/sda
Device: /dev/sda
  CPU  0:                    0 events,        8 KiB data
  CPU  1:                    0 events,        0 KiB data
  Total:                     0 events (dropped 0),        8 KiB data
# ls -l physical.blktrace.*
-rw-r--r-- 1 root root 7968 May  6 10:20 physical.blktrace.0
-rw-r--r-- 1 root root    0 May  6 10:20 physical.blktrace.1
# blktrace -w 30 -o logical -d /dev/mapper/VolGroup00-LogVol00
Device: /dev/mapper/VolGroup00-LogVol00
  CPU  0:                    0 events,        2 KiB data
  CPU  1:                    0 events,        0 KiB data
  Total:                     0 events (dropped 0),        2 KiB data
# ls -l logical.blktrace.*
-rw-r--r-- 1 root root 1680 May  6 10:22 logical.blktrace.0
-rw-r--r-- 1 root root    0 May  6 10:22 logical.blktrace.1
[root@hp-lp1 ~]# blktrace -w 30 -o - -d /dev/mapper/VolGroup00-LogVol00 | blkiomon -I 10 -h -
# echo $?
0

Actual results:
blkiomon is quiet

Expected results:
blkiomon prints I/O statistics
Comment 1 Eric Sandeen 2009-05-06 12:18:09 EDT
This is somewhat expected, based on the original design intent:

DESCRIPTION
       blkiomon is a block device I/O monitor. It periodically  generates  per
       device  request size and request latency statistics from blktrace data.
       It provides histograms as well as data that can be  used  to  calculate
       min,  max,  average and variance. For this purpose, it consumes D and C
       traces read from stdin.

and from blkparse C and D traces are:

       C -- complete A previously issued request has been completed.  The out-
           put will detail the sector and size of that request, as well as the
           success or failure of it.

       D -- issued A request that previously resided on the block layer  queue
           or in the i/o scheduler has been sent to the driver.

but the higher-level drivers never see these completions ... I'm not sure we can make this work for anything above the /dev/sd* devices.

        /* we need an older D trace and a younger C trace */
        if (t_old->bit.action & BLK_TC_ACT(BLK_TC_ISSUE) &&
            t_young->bit.action & BLK_TC_ACT(BLK_TC_COMPLETE)) {
                /* matching D and C traces - update statistics */
                match++;
                blkiomon_account(&t_old->bit, &t_young->bit);
                blkiomon_free_trace(t_stored);
                return t;
        }

/dev/dm-* and /dev/md* won't see those BLK_TC_COMPLETE actions...
Comment 2 Milos Malik 2009-05-07 04:48:07 EDT
Sorry, I should have read the man page more thoroughly.
Comment 3 Eric Sandeen 2009-05-07 11:45:02 EDT
No problem, it's not at all obvious; the manpage should probably be updated to make this more clear.
Comment 5 Eric Sandeen 2009-07-02 12:46:07 EDT
Some of the less critical bugs for blktrace didn't make it for RHEL5.4, but we can get to them in RHEL5.5.

For this one we probably just need a manpage update.

Thanks,
-Eric
Comment 6 RHEL Product and Program Management 2009-11-06 14:25:01 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 Edward Shishkin 2009-12-16 11:17:31 EST
The patch was sent to the upstream
Comment 8 Mike Snitzer 2010-05-14 17:11:50 EDT
(In reply to comment #7)
> The patch was sent to the upstream    

Edward do you have a pointer to that upstream post?  What are the plans for pulling it in to RHEL5.x (and RHEL6)?
Comment 9 Edward Shishkin 2010-05-17 08:09:28 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > The patch was sent to the upstream    
> 
> Edward do you have a pointer to that upstream post?

http://marc.info/?l=linux-btrace&m=126089936523206&w=2

> What are the plans for
> pulling it in to RHEL5.x (and RHEL6)?    

will be pulled
Comment 10 Edward Shishkin 2010-05-17 08:28:37 EDT
sorry, this is the correct pointer:

http://marc.info/?l=linux-btrace&m=126089938423231&w=2
Comment 12 RHEL Product and Program Management 2010-08-09 15:45:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2013-05-01 03:12:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 14 RHEL Product and Program Management 2014-03-07 08:54:54 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 15 RHEL Product and Program Management 2014-06-02 09:22:42 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.