Bug 499446 - some nagios-plugins packages depend upon nagios package (grou
some nagios-plugins packages depend upon nagios package (grou
Status: CLOSED DUPLICATE of bug 469530
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 13:29 EDT by Paul Blankenbaker
Modified: 2009-09-30 16:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 16:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Blankenbaker 2009-05-06 13:29:46 EDT
Description of problem:

The "nagios-plugins-all" package does not depend upon the "nagios" package. However, some of the packages which the "nagios-plugins-all" package pulls in require that the "nagios" group to exist (which is created by the "nagios" package). For example, the "nagios-plugins-fping", produces the following warning if one installs it before installing the "nagios" package:

  warning: group nagios does not exist - using root

When this warning occurs, the plug-in will have its group set to "root" instead of "nagios".

To work around the problem by hand, one simply needs to install the "nagios" package prior to installing any plug-ins.

However, when trying to include "nagios" and the "nagios-plugins" packages within a kickstart file for the creation of a Live CD, the ordering of package installation is based on dependencies in the RPM spec files of each package (we don't think there is a way to force the "nagios" package to be installed prior to the plugins).


Version-Release number of selected component (if applicable):

Fedora 10 RPMs.


How reproducible:

Easily reproducible/demonstrated.


Steps to Reproduce:

1. Start with a Fedora 10 box (i386 or x86_64) which has never had any nagios packages installed (Fedora 10 Live should be sufficient).

2. Install the: nagios-plugins-fping package with yum:

  yum install nagios-plugins-fping

  
Actual results:

The following "warning" appears in the output and the group will be set to "root" instead of "nagios" for the plugin:

Running Transaction
  Installing     : fping                                                    1/3 
  Installing     : nagios-plugins                                           2/3 
  Installing     : nagios-plugins-fping                                     3/3 
warning: group nagios does not exist - using root

Installed:
  nagios-plugins-fping.x86_64 0:1.4.13-11.fc10                                  

Dependency Installed:
  fping.x86_64 0:2.4b2-8.fc9       nagios-plugins.x86_64 0:1.4.13-11.fc10      


Expected results:

  - No warning

  - Installation of nagios (or some other) package to resolve dependency of nagios group


Additional info:

  If it is undesirable to have the nagios plugins depend directly upon the nagios package, then maybe a auxillary package (like: "nagios-user") should be created which has the responsiblity of setting up the nagios user account which is required for the "nagios" package and some of the nagios plugins.

  This wouldn't be a big issue if installing nagios by hand, it is a problem for us as we try to install nagios via a kickstart file to build our 2.10.0 version of the Network Security Toolkit (NST) live ISO image. Installation from a kickstart file relies purely on package dependencies specified in the spec files for determining the order in which packages are installed (we don't know how to force a kickstart file to install nagios before the nagios-plugins).

This bug (and solution) may be related to bug #469530.

Thanks for your time.
Comment 1 Jose Pedro Oliveira 2009-09-30 16:52:29 EDT
Paul,

Known problem. Closing this ticket as a duplicate of #469530

/jpo

PS - Maybe it can be solved in #526561.
Comment 2 Jose Pedro Oliveira 2009-09-30 16:53:03 EDT

*** This bug has been marked as a duplicate of bug 469530 ***

Note You need to log in before you can comment on or make changes to this bug.