Bug 499459 - 'NoneType' object has not attribute 'addPartition'
'NoneType' object has not attribute 'addPartition'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:0ab28383a9542713c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 14:27 EDT by Chris Lumens
Modified: 2009-05-22 09:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 09:11:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (597.48 KB, text/plain)
2009-05-06 14:27 EDT, Chris Lumens
no flags Details
Attached traceback automatically from anaconda. (60.68 KB, text/plain)
2009-05-14 21:52 EDT, Jason Tibbitts
no flags Details
Attached traceback automatically from anaconda. (110.66 KB, text/plain)
2009-05-20 19:57 EDT, Martin Ebourne
no flags Details

  None (edit)
Description Chris Lumens 2009-05-06 14:27:08 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.48 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 1160, in create
    self.disk.addPartition(self)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 671, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 238, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
AttributeError: 'NoneType' object has no attribute 'addPartition'
Comment 1 Chris Lumens 2009-05-06 14:27:14 EDT
Created attachment 342696 [details]
Attached traceback automatically from anaconda.
Comment 2 Jason Tibbitts 2009-05-14 21:52:02 EDT
Created attachment 344070 [details]
Attached traceback automatically from anaconda.
Comment 3 Jason Tibbitts 2009-05-14 21:56:31 EDT
I was trying to pare down my kickstart file from the one used in bug 500932, and ended up generating a different backtrace.  Perhaps it's really the same thing.

The kickstart file used is:

lang en_US
keyboard "us"
install
skipx
reboot

zerombr
clearpart --all
part /boot --fstype ext3 --size 256
part pv.0 --size=1000000 --grow
volgroup vg0 pv.0
logvol / --fstype ext3 --name=root --vgname=vg0 --size=102400

%packages --nobase
autofs
krb5-workstation
mailx
man
nfs-utils
nss_ldap
ntp
openssh-server
pam_krb5
perl
ssmtp
sudo
zsh
%end
Comment 4 David Lehman 2009-05-15 11:28:04 EDT
This should be fixed in anaconda-11.5.0.53-1.
Comment 5 Martin Ebourne 2009-05-20 19:57:14 EDT
Created attachment 344900 [details]
Attached traceback automatically from anaconda.
Comment 6 Martin Ebourne 2009-05-20 19:59:25 EDT
I've just used the boot.iso from rawhide. Is that not fixed yet?
Comment 7 Jason Tibbitts 2009-05-20 21:04:04 EDT
Anaconda should tell you its version when it starts up (after loading install.img).  It looks like your install image is not up to date, as your backtrace shows 11.5.0.52 while today's rawhide has 11.5.0.54.
Comment 8 Martin Ebourne 2009-05-22 06:17:39 EDT
Sorry, missed this earlier. Yes the problem was an outdated mirror and I can confirm that 11.5.0.54 worked correctly.
Comment 9 Chris Lumens 2009-05-22 09:11:44 EDT
Thanks for retesting.

Note You need to log in before you can comment on or make changes to this bug.