Bug 49951 - colors.inc uses the same names for different colors than X11
colors.inc uses the same names for different colors than X11
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: povray (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-25 12:21 EDT by David Nečas
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 08:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nečas 2001-07-25 12:21:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
Some of the colors defined in colors.inc include file uses color names of 
X11 ,named colors` for different colors.

How reproducible:
Always

Steps to Reproduce:
Look at the colors.  I generated this list of different colors:

#declare Gold_X11 = color red 1.00000 green 0.84314 blue 0.00000;
#declare Gold_POV = color red 0.80000 green 0.49804 blue 0.19608;

#declare Aquamarine_X11 = color red 0.49804 green 1.00000 blue 0.83137;
#declare Aquamarine_POV = color red 0.43922 green 0.85882 blue 0.57647;

#declare GreenYellow_X11 = color red 0.67843 green 1.00000 blue 0.18431;
#declare GreenYellow_POV = color red 0.57647 green 0.85882 blue 0.43922;

#declare Firebrick_X11 = color red 0.69804 green 0.13333 blue 0.13333;
#declare Firebrick_POV = color red 0.55686 green 0.13725 blue 0.13725;

#declare Grey_X11 = color red 0.74510 green 0.74510 blue 0.74510;
#declare Grey_POV = color red 0.75294 green 0.75294 blue 0.75294;

#declare MediumAquamarine_X11 = color red 0.40000 green 0.80392 blue 
0.66667;
#declare MediumAquamarine_POV = color red 0.19608 green 0.80000 blue 
0.60000;

#declare CornflowerBlue_X11 = color red 0.39216 green 0.58431 blue 0.92941;
#declare CornflowerBlue_POV = color red 0.25882 green 0.25882 blue 0.43529;

#declare MediumTurquoise_X11 = color red 0.28235 green 0.81961 blue 
0.80000;
#declare MediumTurquoise_POV = color red 0.43922 green 0.85882 blue 
0.85882;

#declare Salmon_X11 = color red 0.98039 green 0.50196 blue 0.44706;
#declare Salmon_POV = color red 0.43529 green 0.25882 blue 0.25882;

#declare Turquoise_X11 = color red 0.25098 green 0.87843 blue 0.81569;
#declare Turquoise_POV = color red 0.67843 green 0.91765 blue 0.91765;

#declare Pink_X11 = color red 1.00000 green 0.75294 blue 0.79608;
#declare Pink_POV = color red 0.73725 green 0.56078 blue 0.56078;

#declare IndianRed_X11 = color red 0.80392 green 0.36078 blue 0.36078;
#declare IndianRed_POV = color red 0.30980 green 0.18431 blue 0.18431;

#declare Orchid_X11 = color red 0.85490 green 0.43922 blue 0.83922;
#declare Orchid_POV = color red 0.85882 green 0.43922 blue 0.85882;

#declare SkyBlue_X11 = color red 0.52941 green 0.80784 blue 0.92157;
#declare SkyBlue_POV = color red 0.19608 green 0.60000 blue 0.80000;

#declare DarkOliveGreen_X11 = color red 0.33333 green 0.41961 blue 0.18431;
#declare DarkOliveGreen_POV = color red 0.30980 green 0.30980 blue 0.18431;

#declare LightGray_X11 = color red 0.82745 green 0.82745 blue 0.82745;
#declare LightGray_POV = color red 0.65882 green 0.65882 blue 0.65882;

#declare Violet_X11 = color red 0.93333 green 0.50980 blue 0.93333;
#declare Violet_POV = color red 0.30980 green 0.18431 blue 0.30980;

#declare Navy_X11 = color red 0.00000 green 0.00000 blue 0.50196;
#declare Navy_POV = color red 0.13725 green 0.13725 blue 0.55686;

#declare Orange_X11 = color red 1.00000 green 0.64706 blue 0.00000;
#declare Orange_POV = color red 1.00000 green 0.50000 blue 0.00000;

#declare LightBlue_X11 = color red 0.67843 green 0.84706 blue 0.90196;
#declare LightBlue_POV = color red 0.74902 green 0.84706 blue 0.84706;

#declare LightGrey_X11 = color red 0.82745 green 0.82745 blue 0.82745;
#declare LightGrey_POV = color red 0.65882 green 0.65882 blue 0.65882;

#declare Sienna_X11 = color red 0.62745 green 0.32157 blue 0.17647;
#declare Sienna_POV = color red 0.55686 green 0.41961 blue 0.13725;

#declare Tan_X11 = color red 0.82353 green 0.70588 blue 0.54902;
#declare Tan_POV = color red 0.85882 green 0.57647 blue 0.43922;

#declare DarkSlateBlue_X11 = color red 0.28235 green 0.23922 blue 0.54510;
#declare DarkSlateBlue_POV = color red 0.11961 green 0.13725 blue 0.55686;

#declare DimGray_X11 = color red 0.41176 green 0.41176 blue 0.41176;
#declare DimGray_POV = color red 0.32941 green 0.32941 blue 0.32941;

#declare PaleGreen_X11 = color red 0.59608 green 0.98431 blue 0.59608;
#declare PaleGreen_POV = color red 0.56078 green 0.73725 blue 0.56078;

#declare BlueViolet_X11 = color red 0.54118 green 0.16863 blue 0.88627;
#declare BlueViolet_POV = color red 0.62352 green 0.37255 blue 0.62353;

#declare Goldenrod_X11 = color red 0.85490 green 0.64706 blue 0.12549;
#declare Goldenrod_POV = color red 0.85882 green 0.85882 blue 0.43922;

#declare ForestGreen_X11 = color red 0.13333 green 0.54510 blue 0.13333;
#declare ForestGreen_POV = color red 0.13725 green 0.55686 blue 0.13725;

#declare DimGrey_X11 = color red 0.41176 green 0.41176 blue 0.41176;
#declare DimGrey_POV = color red 0.32941 green 0.32941 blue 0.32941;

#declare Wheat_X11 = color red 0.96078 green 0.87059 blue 0.70196;
#declare Wheat_POV = color red 0.84706 green 0.84706 blue 0.74902;

#declare MediumVioletRed_X11 = color red 0.78039 green 0.08235 blue 
0.52157;
#declare MediumVioletRed_POV = color red 0.85882 green 0.43922 blue 
0.57647;

#declare MediumBlue_X11 = color red 0.00000 green 0.00000 blue 0.80392;
#declare MediumBlue_POV = color red 0.19608 green 0.19608 blue 0.80000;

#declare NavyBlue_X11 = color red 0.00000 green 0.00000 blue 0.50196;
#declare NavyBlue_POV = color red 0.13725 green 0.13725 blue 0.55686;

#declare MediumSeaGreen_X11 = color red 0.23529 green 0.70196 blue 0.44314;
#declare MediumSeaGreen_POV = color red 0.25882 green 0.43529 blue 0.25882;

#declare Maroon_X11 = color red 0.69020 green 0.18824 blue 0.37647;
#declare Maroon_POV = color red 0.55686 green 0.13725 blue 0.41961;

#declare DarkGreen_X11 = color red 0.00000 green 0.39216 blue 0.00000;
#declare DarkGreen_POV = color red 0.18431 green 0.30980 blue 0.18431;

#declare VioletRed_X11 = color red 0.81569 green 0.12549 blue 0.56471;
#declare VioletRed_POV = color red 0.80000 green 0.19608 blue 0.60000;

#declare DarkTurquoise_X11 = color red 0.00000 green 0.80784 blue 0.81961;
#declare DarkTurquoise_POV = color red 0.43922 green 0.57647 blue 0.85882;

#declare Plum_X11 = color red 0.86667 green 0.62745 blue 0.86667;
#declare Plum_POV = color red 0.91765 green 0.67843 blue 0.91765;

#declare Khaki_X11 = color red 0.94118 green 0.90196 blue 0.54902;
#declare Khaki_POV = color red 0.62353 green 0.62353 blue 0.37255;

#declare SteelBlue_X11 = color red 0.27451 green 0.50980 blue 0.70588;
#declare SteelBlue_POV = color red 0.13725 green 0.41961 blue 0.55686;

#declare Coral_X11 = color red 1.00000 green 0.49804 blue 0.31373;
#declare Coral_POV = color red 1.00000 green 0.49804 blue 0.00000;

#declare SeaGreen_X11 = color red 0.18039 green 0.54510 blue 0.34118;
#declare SeaGreen_POV = color red 0.13725 green 0.55686 blue 0.41961;

#declare MidnightBlue_X11 = color red 0.09804 green 0.09804 blue 0.43922;
#declare MidnightBlue_POV = color red 0.18431 green 0.18431 blue 0.30980;

#declare MediumOrchid_X11 = color red 0.72941 green 0.33333 blue 0.82745;
#declare MediumOrchid_POV = color red 0.57647 green 0.43922 blue 0.85882;

#declare Gray_X11 = color red 0.74510 green 0.74510 blue 0.74510;
#declare Gray_POV = color red 0.75294 green 0.75294 blue 0.75294;

#declare LightSteelBlue_X11 = color red 0.69020 green 0.76863 blue 0.87059;
#declare LightSteelBlue_POV = color red 0.56078 green 0.56078 blue 0.73725;




Additional info:

This is not a bug in strict sense, however, it's annoying and a possible 
source of confusion (it took me a while to find out why colors picked in 
gcolorsel may look so different in povray).  It's also too late to do 
anything with it, however, it should be at least mentioned in the 
documentation.
Comment 1 Need Real Name 2001-08-08 08:44:43 EDT
Please remember that POV-Ray and its roots go back to 1990 and the Amiga 500. The 

first X port was for a Sun 3 with a black and white display. X10/X11 was no 

accepted standard at this time on the desktop platforms!



It should in no way be surprising that a program that is available for many 

different operating systems cannot follow the definitions of all of them.  In 

particular with colors, should colors look different when rendered on Windows, 

Mac OS, or on a system using X11?



The color names and their values are defined so they give good looking images on 

all operating systems and display managers. Thus, it is not a bug that the colors 

don't match those of the (one specific?) X11 implementation, but simply an 

incorrect assumption made by a user.

Comment 2 David Nečas 2001-08-08 09:25:19 EDT
Sigh.  Either you interpret it X11 uses different colors than PoV-Ray or PoV-
Ray uses different colors than X11 (BTW, X11 colors were considered by W3C for 
inclusion in the HTML standard, though they were not adopted), the colors are 
different.

I didn't request changing the colors, neither PoV-Ray nor X11, I requested 
mentioning it somewhere (well, I appended `at least' after that, I'm sorry for 
that), because it may confuse other people used to X11 colors too.  It seems 
much more logical to mention it in PoV-Ray [UNIX specific?] docs than in X11.  
Am I asking too much?

OK, I'm closing this bug as NOTABUG.  However, not-a-bug is not the same as not-
a-problem.

Note You need to log in before you can comment on or make changes to this bug.