Bug 499514 - EFI boot loader not installed correctly
EFI boot loader not installed correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-05-06 18:10 EDT by Jesse Keating
Modified: 2013-01-09 22:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 16:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
program log (12.80 KB, text/plain)
2009-05-06 18:10 EDT, Jesse Keating
no flags Details
storage log (107.74 KB, text/plain)
2009-05-06 18:10 EDT, Jesse Keating
no flags Details
anaconda log (72.52 KB, text/plain)
2009-05-06 18:11 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2009-05-06 18:10:19 EDT
Created attachment 342742 [details]
program log

I just did an EFI install on rawhide x86_64 from 20090506, and once done My boot loader didn't see any option to boot Fedora, only the existing OS X.  I'm attaching anaconda,storage,program log files.
Comment 1 Jesse Keating 2009-05-06 18:10:51 EDT
Created attachment 342743 [details]
storage log
Comment 2 Jesse Keating 2009-05-06 18:11:31 EDT
Created attachment 342744 [details]
anaconda log
Comment 3 Jesse Keating 2009-05-06 18:30:09 EDT
Hrm, I think I had it wrong.  I was holding down option so that I could see and choose what to boot from, and I didn't see a Fedora option.  But if I don't hold down anything I got Fedora.  So maybe I'm just a tad confused on things.
Comment 4 Peter Jones 2009-05-07 16:08:54 EDT
Holding down option will give you a list of devices that appear bootable, but that has nothing to do with the actual boot order.  If you select a device that way, it'll try to boot it according to the method for booting from block devices, which will get you MacOS because they implemented it so it'd search HFS+ instead of the EFI System Partition.

If you /don't/ hold down option, it'll use the EFI BootDevice variable, which is where we set up booting.  So this appears to be working correctly.

Note You need to log in before you can comment on or make changes to this bug.