Bug 499523 - Fedora 11 Preview installer crashes after attempt to create a partition
Fedora 11 Preview installer crashes after attempt to create a partition
Status: CLOSED DUPLICATE of bug 495433
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:726a40cf9fd375536...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 21:27 EDT by werdberd
Modified: 2011-09-13 21:14 EDT (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 09:56:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (70.67 KB, text/plain)
2009-05-06 21:27 EDT, werdberd
no flags Details
Attached traceback automatically from anaconda. (146.67 KB, text/plain)
2009-06-18 10:31 EDT, Anoop Panavalappil
no flags Details
Attached traceback automatically from anaconda. (160.01 KB, text/plain)
2009-06-23 18:24 EDT, a johnson
no flags Details
Attached traceback automatically from anaconda. (90.88 KB, text/plain)
2009-07-06 20:36 EDT, bugchaser
no flags Details
Attached traceback automatically from anaconda. (302.67 KB, text/plain)
2009-07-06 20:43 EDT, bugchaser
no flags Details
Attached traceback automatically from anaconda. (217.10 KB, text/plain)
2009-07-19 20:22 EDT, bugchaser
no flags Details
Attached traceback automatically from anaconda. (106.13 KB, text/plain)
2009-07-22 00:33 EDT, apresh.saxena
no flags Details
Attached traceback automatically from anaconda. (96.35 KB, text/plain)
2009-07-22 06:38 EDT, william
no flags Details
Attached traceback automatically from anaconda. (363.22 KB, text/plain)
2009-07-22 14:45 EDT, Matej
no flags Details
Attached traceback automatically from anaconda. (86.53 KB, text/plain)
2009-07-31 23:51 EDT, bugchaser
no flags Details
Attached traceback automatically from anaconda. (97.38 KB, text/plain)
2009-08-02 05:34 EDT, avi
no flags Details
Attached traceback automatically from anaconda. (97.05 KB, text/plain)
2009-08-02 05:40 EDT, avi
no flags Details
Attached traceback automatically from anaconda. (446.89 KB, text/plain)
2009-08-08 10:12 EDT, Bobby
no flags Details
Attached traceback automatically from anaconda. (100.17 KB, text/plain)
2009-08-14 23:08 EDT, lifeng
no flags Details
Attached traceback automatically from anaconda. (137.47 KB, text/plain)
2009-08-17 10:45 EDT, CuMorrigu
no flags Details
Attached traceback automatically from anaconda. (549.75 KB, text/plain)
2009-09-16 13:23 EDT, adrianvnc
no flags Details
Attached traceback automatically from anaconda. (162.60 KB, text/plain)
2009-09-18 20:17 EDT, orti1980
no flags Details
Attached traceback automatically from anaconda. (151.46 KB, text/plain)
2009-10-01 17:45 EDT, Nitin
no flags Details
Attached traceback automatically from anaconda. (66.25 KB, text/plain)
2009-10-21 11:01 EDT, Cam
no flags Details
Attached traceback automatically from anaconda. (494.14 KB, text/plain)
2009-11-08 05:28 EST, nigham
no flags Details
Attached traceback automatically from anaconda. (135.75 KB, text/plain)
2009-11-12 07:45 EST, bender
no flags Details
Attached traceback automatically from anaconda. (931.34 KB, text/plain)
2009-11-13 00:48 EST, TIm
no flags Details
Attached traceback automatically from anaconda. (1.01 MB, text/plain)
2009-11-13 00:54 EST, TIm
no flags Details
Attached traceback automatically from anaconda. (109.64 KB, text/plain)
2009-11-24 06:12 EST, jyf
no flags Details
Attached traceback automatically from anaconda. (98.32 KB, text/plain)
2010-01-08 20:44 EST, fauzi
no flags Details
Attached traceback automatically from anaconda. (113.78 KB, text/plain)
2010-05-02 10:19 EDT, Millind Nagmoti
no flags Details
Attached traceback automatically from anaconda. (72.85 KB, text/plain)
2011-01-23 10:35 EST, anhnd54cc
no flags Details
Attached traceback automatically from anaconda. (365.02 KB, text/plain)
2011-09-13 21:14 EDT, Edwin
no flags Details

  None (edit)
Description werdberd 2009-05-06 21:27:45 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/geometry.py", line 128, in intersect
    return Geometry(PedGeometry=self.__geometry.intersect(b.getPedGeometry()))
  File "/usr/lib/anaconda/storage/partitioning.py", line 488, in getBestFreeSpaceRegion
    free_geom = extended.geometry.intersect(_range)
  File "/usr/lib/anaconda/storage/partitioning.py", line 705, in allocatePartitions
    boot=_part.req_bootable)
  File "/usr/lib/anaconda/storage/partitioning.py", line 566, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1005, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1113, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 962, in newCB
    self.editPartition(device, isNew=1)
CreateException: Error opening /dev/sdc: No medium found
Comment 1 werdberd 2009-05-06 21:27:57 EDT
Created attachment 342753 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-05-07 09:56:47 EDT

*** This bug has been marked as a duplicate of bug 495433 ***
Comment 3 Anoop Panavalappil 2009-06-18 10:31:42 EDT
Created attachment 348481 [details]
Attached traceback automatically from anaconda.
Comment 4 a johnson 2009-06-23 18:24:56 EDT
Created attachment 349162 [details]
Attached traceback automatically from anaconda.
Comment 5 a johnson 2009-06-23 19:08:35 EDT
I problem is a little different the drive that anaconda doesn't see is my main internal drive that I have partition to hold win_xp and fedora 9.  I enter the install process and get to selecting the install location.  the preferred and usual the one that works deleting the exist ext3 partition and creating a new
/(root) partition and the install proceeds from there. but this is were I get the bug about unable to open the drive.  I do have a built in card read and several usb ports on my computer and some are used but nothing in the card reader.
Comment 6 bugchaser 2009-07-06 20:36:45 EDT
Created attachment 350704 [details]
Attached traceback automatically from anaconda.
Comment 7 bugchaser 2009-07-06 20:39:25 EDT
Comment on attachment 350704 [details]
Attached traceback automatically from anaconda.

I have had a few installation errors like this one. Anything that is not a default install seems to cause problems, as well as the new ext4 format conflicting with ext3 in various ways during install.
Comment 8 bugchaser 2009-07-06 20:43:04 EDT
Created attachment 350706 [details]
Attached traceback automatically from anaconda.
Comment 9 bugchaser 2009-07-19 20:22:05 EDT
Created attachment 354294 [details]
Attached traceback automatically from anaconda.
Comment 10 apresh.saxena 2009-07-22 00:33:57 EDT
Created attachment 354648 [details]
Attached traceback automatically from anaconda.
Comment 11 william 2009-07-22 06:38:29 EDT
Created attachment 354667 [details]
Attached traceback automatically from anaconda.
Comment 12 Matej 2009-07-22 14:45:26 EDT
Created attachment 354771 [details]
Attached traceback automatically from anaconda.
Comment 13 bugchaser 2009-07-31 23:51:30 EDT
Created attachment 355873 [details]
Attached traceback automatically from anaconda.
Comment 14 avi 2009-08-02 05:34:21 EDT
Created attachment 355930 [details]
Attached traceback automatically from anaconda.
Comment 15 avi 2009-08-02 05:40:42 EDT
Created attachment 355931 [details]
Attached traceback automatically from anaconda.
Comment 16 Bobby 2009-08-08 10:12:21 EDT
Created attachment 356774 [details]
Attached traceback automatically from anaconda.
Comment 17 lifeng 2009-08-14 23:08:06 EDT
Created attachment 357528 [details]
Attached traceback automatically from anaconda.
Comment 18 CuMorrigu 2009-08-17 10:45:13 EDT
Created attachment 357657 [details]
Attached traceback automatically from anaconda.
Comment 19 adrianvnc 2009-09-16 13:23:43 EDT
Created attachment 361330 [details]
Attached traceback automatically from anaconda.
Comment 20 orti1980 2009-09-18 20:17:56 EDT
Created attachment 361732 [details]
Attached traceback automatically from anaconda.
Comment 21 Nitin 2009-10-01 17:45:32 EDT
Created attachment 363400 [details]
Attached traceback automatically from anaconda.
Comment 22 Cam 2009-10-21 11:01:24 EDT
Created attachment 365521 [details]
Attached traceback automatically from anaconda.
Comment 23 nigham 2009-11-08 05:28:55 EST
Created attachment 368031 [details]
Attached traceback automatically from anaconda.
Comment 24 bender 2009-11-12 07:45:52 EST
Created attachment 369208 [details]
Attached traceback automatically from anaconda.
Comment 25 TIm 2009-11-13 00:48:38 EST
Created attachment 369371 [details]
Attached traceback automatically from anaconda.
Comment 26 TIm 2009-11-13 00:54:06 EST
Created attachment 369372 [details]
Attached traceback automatically from anaconda.
Comment 27 jyf 2009-11-24 06:12:22 EST
Created attachment 373384 [details]
Attached traceback automatically from anaconda.
Comment 28 fauzi 2010-01-08 20:44:45 EST
Created attachment 382589 [details]
Attached traceback automatically from anaconda.
Comment 29 Millind Nagmoti 2010-05-02 10:19:43 EDT
Created attachment 410805 [details]
Attached traceback automatically from anaconda.
Comment 30 anhnd54cc 2011-01-23 10:35:31 EST
Created attachment 474824 [details]
Attached traceback automatically from anaconda.
Comment 31 Edwin 2011-09-13 21:14:08 EDT
Created attachment 523035 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.