Bug 499555 - virtinst: Debian Lenny cannot handle virtio NIC
Summary: virtinst: Debian Lenny cannot handle virtio NIC
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-virtinst
Version: 11
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F11VirtTarget
TreeView+ depends on / blocked
 
Reported: 2009-05-07 07:17 UTC by Rainer Koenig
Modified: 2009-06-19 12:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-18 14:59:40 UTC


Attachments (Terms of Use)

Description Rainer Koenig 2009-05-07 07:17:05 UTC
Description of problem:
Tried a installation from the Debian/Lenny netinstall CD. Installation fails if you use the OS settings "Linux/Debian Lenny" due to a not found network card.

Version-Release number of selected component (if applicable):
virt-manager-0.7.0-4.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Put Debian netinstall CD in to CD drive
2. Create a virtual guest with OS settings "Debian/Lenny"
3. Go to the installation steps
  
Actual results:
Debian installer is reporting "no network card found"

Expected results:
Usage of RTL8130 card

Additional info:
A boot with Knoppix (based on Debian/Sid) shows the cause of the problem. 

If you use the setting "Linux/Generic 2.6.25 or later kernel with virtio" you get the same problems in Knoppix reporting a strange network card in lspci.

If you boot Knoppic with "Linux/Generic 2.6.x kernel" lspci will report the RTL8139 NIC as expected.

Installting Debian/Lenny with settings "Linux/Generic 2.6.x kernel" works as well then.

Comment 1 Mark McLoughlin 2009-05-07 07:27:51 UTC
Okay, interesting - Lenny doesn't work with virtio-net

Comment 2 Bug Zapper 2009-06-09 15:17:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Guido Günther 2009-06-15 20:22:24 UTC
Doublechecked with 

http://cdimage.debian.org/debian-cd/5.0.1/i386/iso-cd/debian-501-i386-businesscard.iso

Works without problems.

Comment 4 Cole Robinson 2009-06-15 20:36:31 UTC
Rainer, can you still reproduce?

Comment 5 Rainer Koenig 2009-06-16 05:44:30 UTC
Cole, I'm sorry but actually I have no system ready for a test in my lab and due to my tight work schedule it will take some time until I'm able to try out things with the F11 final and the latest Debian release. So I would believe in Guido's results since he was using a newer version of the Debian Netinstall than I was doing. 

Regards
Rainer

Comment 6 Cole Robinson 2009-06-18 14:59:40 UTC
Okay, closing as NOTABUG.

But out of curiousity, there are different versions of the debian install cds for the same released distro? That kind of stinks, since it means the OS dictionary settings will only work with sufficiently recent install CDs.

Comment 7 Guido Günther 2009-06-19 10:04:23 UTC
Yes, this sometimes is necessary to fix critical bugs in the installer. The OSDict should reflect the minimal set of features supported (as of 5.0.0). Virtio worked from the beginning and even in prereleases.

Comment 8 Cole Robinson 2009-06-19 12:53:23 UTC
Thanks Guido, good to know.


Note You need to log in before you can comment on or make changes to this bug.