Bug 499564 - Starting MonitoringScout on Satellite says FAIL where InstallSoftwareConfig says OK on Proxy
Starting MonitoringScout on Satellite says FAIL where InstallSoftwareConfig s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
wes hayutin
:
Depends On:
Blocks: 456999 463877
  Show dependency treegraph
 
Reported: 2009-05-07 04:37 EDT by Jan Pazdziora
Modified: 2009-09-10 10:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-05-07 04:37:47 EDT
Description of problem:

When starting monitoring scout on Satellite, the first line is FAIL.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090505.1 on i386

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have Satellite with monitoring and scout enabled.
2. Run service MonitoringScout stop
3. Run service MonitoringScout start
  
Actual results:

# service MonitoringScout start
Starting MonitoringScout ...  [ FAIL ]
Starting NPBootstrap ...  [ OK ]
Starting SputLite ...  [ OK ]
Starting Dequeuer ...  [ OK ]
Starting Dispatcher ...  [ OK ]
[ OK ]
#

Expected results:

# service MonitoringScout start
Starting MonitoringScout ...  [ OK ]
Starting NPBootstrap ...  [ OK ]
Starting SputLite ...  [ OK ]
Starting Dequeuer ...  [ OK ]
Starting Dispatcher ...  [ OK ]
[ OK ]
#

or 

# service MonitoringScout start
Starting MonitoringScout ...  Starting NPBootstrap ...  [ OK ]
Starting SputLite ...  [ OK ]
Starting Dequeuer ...  [ OK ]
Starting Dispatcher ...  [ OK ]
[ OK ]
#

or

# service MonitoringScout start
Starting MonitoringScout ...  Starting InstallSoftwareConfig ...  [ OK ]
Starting NPBootstrap ...  [ OK ]
Starting SputLite ...  [ OK ]
Starting Dequeuer ...  [ OK ]
Starting Dispatcher ...  [ OK ]
[ OK ]
#

Additional info:

I for long thought that that FAIL should be there but now I saw MonitoringScout on RHN Proxy and it shows that InstallSoftwareConfig and OK, that's why this bugzilla.
Comment 1 Milan Zazrivec 2009-05-13 05:55:04 EDT
The reproducer is in fact:
1. enable monitoring + monitoring scout
2. # service MonitoringScout stop
3. # service Monitoring stop
4. # service Monitoring start
5. # service MonitoringScout start

spacewalk.git master: 18d0598b263ab20d04cad9d0bf6ccf001199ac84
spacewalk.git VADER: 39047dc2057c031fb6786e989c620eba23213f3d
Comment 2 Milan Zazrivec 2009-05-20 15:24:04 EDT
SatConfig-general-1.216.8-3
Comment 3 wes hayutin 2009-05-28 11:06:36 EDT
5/21.1 verified

[root@grandprix .ssh]# service MonitoringScout stop
Stopping MonitoringScout ...  Stopping Dispatcher ...  [ OK ]
Stopping Dequeuer ...  [ OK ]
Stopping SputLite ...  [ OK ]
Stopping NPBootstrap ...  [ OK ]
[ OK ]
[root@grandprix .ssh]# service Monitoring stop
Stopping Monitoring ...  Stopping TSDBLocalQueue ...  [ OK ]
Stopping AckProcessor ...  [ OK ]
Stopping Notifier ...  [ OK ]
Stopping NotifLauncher ...  [ OK ]
Stopping NotifEscalator ...  [ OK ]
Stopping GenerateNotifConfig ...  [ OK ]
Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
[root@grandprix .ssh]# service Monitoring start
Starting Monitoring ...  Starting InstallSoftwareConfig ...  [ OK ]
Starting GenerateNotifConfig ...  [ OK ]
Starting NotifEscalator ...  [ OK ]
Starting NotifLauncher ...  [ OK ]
Starting Notifier ...  [ OK ]
Starting AckProcessor ...  [ OK ]
Starting TSDBLocalQueue ...  [ OK ]
[ OK ]
[root@grandprix .ssh]# service MonitoringScout start
Starting MonitoringScout ...  Starting NPBootstrap ...  [ OK ]
Starting SputLite ...  [ OK ]
Starting Dequeuer ...  [ OK ]
Starting Dispatcher ...  [ OK ]
[ OK ]
[root@grandprix .ssh]#
Comment 4 Michael Mráka 2009-06-17 17:22:36 EDT
This change has broken MonitoringScout on proxy:

[root@xen84 ~]# service MonitoringScout restart
Stopping MonitoringScout ...  Stopping Dispatcher ...  [ OK ]
Stopping Dequeuer ...  [ OK ]
Stopping SputLite ...  [ OK ]
Stopping NPBootstrap ...  [ OK ]
[ OK ]
Starting MonitoringScout ...  Starting NPBootstrap ...  2009-06-18 01:28:50 NPBootstrap:   !! ERROR FROM SHELL COMMAND: 
2009-06-18 01:28:50 NPBootstrap:        !! STDOUT: 
2009-06-18 01:28:50 NPBootstrap:        !! STDERR: Can't call method "get" on an undefined value at /usr/bin/npBootstrap.pl line 15.

2009-06-18 01:28:50 NPBootstrap:        !! EXIT: 512
[ FAIL ]
2009-06-18 01:28:50 NPBootstrap: WARNING: STARTED BUT *NOT* RUNNING
2009-06-18 01:28:50 NPBootstrap: ERRORS ENCOUNTERED DURING LAST ACTION:
2009-06-18 01:28:50 NPBootstrap:        !! ERROR FROM SHELL COMMAND: 
2009-06-18 01:28:50 NPBootstrap:        !! STDOUT: 
2009-06-18 01:28:50 NPBootstrap:        !! STDERR: Can't call method "get" on an undefined value at /usr/bin/npBootstrap.pl line 15.

2009-06-18 01:28:50 NPBootstrap:        !! EXIT: 512
Starting SputLite ...  2009-06-18 01:28:50 SputLite:    !! ERROR FROM SHELL COMMAND: 
2009-06-18 01:28:50 SputLite:   !! STDOUT: 
2009-06-18 01:28:50 SputLite:   !! STDERR: 
2009-06-18 01:28:50 SputLite:   !! EXIT: 512
[ FAIL ]
Comment 5 Michael Mráka 2009-06-17 17:25:10 EDT
New testplan is:
1. install satellite w/ enabled monitoring + monitoring scout
2. # service MonitoringScout stop
3. # service Monitoring stop
4. # service Monitoring start
5. # service MonitoringScout start

6. install proxy w/ enabled monitoring
7. # service MonitoringScout restart
Comment 6 Miroslav Suchý 2009-06-18 04:12:29 EDT
I reverted previous work in commit 6e7965a16a43144325cd2b0ce194dbe7935e351e
The FAIL was actually 'ALREADY RUNNING', which we can safely ignore for InstallSoftwareConfig, since it is not real service.
Commited as cfbabf967571a0774ca289f0b45f0eae99a09716
And I made the output little bit nicer in commit 49d2915150baa29a4f7ca76f1b30898dd7d9eee3
Comment 7 Milan Zazrivec 2009-06-20 04:59:33 EDT
SatConfig-general-1.216.8-4
Comment 8 wes hayutin 2009-06-25 13:29:50 EDT
on a satellite proxy restarting the monitoringScout seems to work fine

[root@dhcp77-204 ~]# /etc/init.d/MonitoringScout restart
Stopping MonitoringScout ...  
	Stopping Dispatcher ...  [ OK ]
	Stopping Dequeuer ...  [ OK ]
	Stopping SputLite ...  [ OK ]
	Stopping NPBootstrap ...  [ OK ]
	Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
Starting MonitoringScout ...  
	Starting InstallSoftwareConfig ...  [ OK ]
	Starting NPBootstrap ...  [ OK ]
	Starting SputLite ...  [ OK ]
	Starting Dequeuer ...  [ OK ]
	Starting Dispatcher ...  [ OK ]
[ OK ]
[root@dhcp77-204 ~]# /etc/init.d/MonitoringScout status
2009-06-09 14:35:07 MonitoringScout: ----------- InstallSoftwareConfig STATUS ---------------
2009-06-09 14:35:07 MonitoringScout: ----------- NPBootstrap STATUS ---------------
2009-06-09 14:35:07 MonitoringScout: ----------- SputLite STATUS ---------------
2009-06-09 14:35:07 MonitoringScout: ----------- Dequeuer STATUS ---------------
2009-06-09 14:35:07 MonitoringScout: ----------- Dispatcher STATUS ---------------
[root@dhcp77-204 ~]#
Comment 9 Miroslav Suchý 2009-08-19 10:37:07 EDT
[root@msuchy-client ~]# service MonitoringScout restart
Stopping MonitoringScout ...
        Stopping Dispatcher ...  [ OK ]
        Stopping Dequeuer ...  [ OK ]
        Stopping SputLite ...  [ OK ]
        Stopping NPBootstrap ...  [ OK ]
        Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
Starting MonitoringScout ...
        Starting InstallSoftwareConfig ...  [ OK ]
        Starting NPBootstrap ...  [ OK ]
        Starting SputLite ...  [ OK ]
        Starting Dequeuer ...  [ OK ]
        Starting Dispatcher ...  [ OK ]
[ OK ]

verified in stage
Comment 10 Brandon Perkins 2009-09-10 10:38:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.