Bug 499570 - No X after upgrade to xorg-x11-drv-nouveau-0.0.12-33.20090501gitf69b34a / nouveau_dri.so missing
No X after upgrade to xorg-x11-drv-nouveau-0.0.12-33.20090501gitf69b34a / nou...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 05:00 EDT by Niels Haase
Modified: 2009-05-07 15:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 08:21:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log from all upgrade packages at once (4.71 KB, text/plain)
2009-05-07 05:00 EDT, Niels Haase
no flags Details
Xorg.log (17.64 KB, text/plain)
2009-05-07 05:01 EDT, Niels Haase
no flags Details

  None (edit)
Description Niels Haase 2009-05-07 05:00:42 EDT
Created attachment 342807 [details]
yum log from all upgrade packages at once

Description of problem:
After upgrade some X related packages (please see yum.log for a complete list) X won't start any more. The last line in Xorg.0.log show a missing nouveau_dri.so file

(EE) AIGLX error: dlopen of /usr/lib64/dri/nouveau_dri.so failed (/usr/lib64/dri
/nouveau_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Loaded and initialized /usr/lib64/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.12-33.20090501gitf69b34a.fc11.x86_64
xorg-x11-server-common-1.6.1-11.fc11.x86_64
xorg-x11-server-Xorg-1.6.1-11.fc11.x86_64
kernel-2.6.29.2-126.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot up the system
2. enjoy the beautiful KMS 
3. see a black screen (while try to start gdm)
  
Actual results:
No X

Expected results:
X

Additional info:
Comment 1 Niels Haase 2009-05-07 05:01:31 EDT
Created attachment 342808 [details]
Xorg.log
Comment 2 Ben Skeggs 2009-05-07 07:58:20 EDT
It was the xorg-x11-server-Xorg update that broke things here, there's a fixed version of the nouveau driver at http://koji.fedoraproject.org/koji/taskinfo?taskID=1340540 however.
Comment 3 Jóhann B. Guðmundsson 2009-05-07 08:14:29 EDT
Updating to -34 fixes this issue for me.
Comment 4 Ben Skeggs 2009-05-07 08:21:00 EDT
Excellent, thanks for testing!
Comment 5 Niels Haase 2009-05-07 15:06:59 EDT
Same for me, big thanks for the quick response Ben!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.