Bug 499572 - import fails
import fails
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-basemap (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 05:15 EDT by mommebu
Modified: 2009-05-29 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.99-7.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 22:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mommebu 2009-05-07 05:15:14 EDT
importing the basemap package fails with the following message:
Python 2.5.2 (r252:60911, Sep 30 2008, 15:42:03) 
[GCC 4.3.2 20080917 (Red Hat 4.3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import mpl_toolkits.basemap
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.5/site-packages/mpl_toolkits/basemap/__init__.py", line 1, in <module>
    from basemap import __doc__, __version__
  File "/usr/lib64/python2.5/site-packages/mpl_toolkits/basemap/basemap.py", line 39, in <module>
    import _geoslib, pupynere, netcdftime
  File "/usr/lib64/python2.5/site-packages/mpl_toolkits/basemap/pupynere.py", line 37, in <module>
    from dap.client import open as open_remote
ImportError: No module named dap.client

about the machine/installation:
uname -a
Linux xxxx 2.6.27.21-170.2.56.fc10.x86_64 #1 SMP Mon Mar 23 23:08:10 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Jef Spaleta 2009-05-07 12:24:16 EDT
which python-basemap  package version is this?


crap it looks like this is a real problem which I scewed up when doing my own testing of the update to 0.99.  I have the necessary files locally on the machine I use this on..but they are unpackaged.  Sorry about that.  I'll try to address this as quickly as possible.


-jef
Comment 2 Jef Spaleta 2009-05-07 13:26:53 EDT
Okay can you test out the packages here from koji and see if they work for you?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1340887

If they work for you I'll push this to the updates system for everyone else.

Sorry about that.

-jef
Comment 3 Fedora Update System 2009-05-08 14:27:53 EDT
python-basemap-0.99-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-basemap-0.99-7.fc10
Comment 4 Fedora Update System 2009-05-12 00:13:28 EDT
python-basemap-0.99-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-basemap'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4860
Comment 5 Fedora Update System 2009-05-29 22:31:06 EDT
python-basemap-0.99-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.