Bug 499584 - info balloon is repeated in qemu log once per second
info balloon is repeated in qemu log once per second
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
: 502681 (view as bug list)
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-07 06:26 EDT by Alan Pevec
Modified: 2009-06-05 09:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: 0.6.2-11.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 17:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2009-05-07 06:26:42 EDT
Description of problem:
> info balloon
> balloon: actual=768
is repeated in /var/log/libvirt/qemu/*.log once per second when virt-manager is running.

Version-Release number of selected component (if applicable):
libvirt-0.6.2-4.fc11.x86_64
virt-manager-0.7.0-4.fc11.x86_64

How reproducible:
always with virt-manager running

Steps to Reproduce:
1. start VM using virt-manager
2. tail -f /var/log/libvirt/qemu/VM.log
3.
  
Actual results:
info balloon
balloon: actual=768
is repeated in qemu log

Expected results:
qemu log is not polluted with the regular monitoring output.
Comment 1 Mark McLoughlin 2009-05-07 06:53:38 EDT
So, this is virt-manager doing doing domainGetInfo, right?

We can't avoid logging the monitor commands, but can we avoid doing the monitor command every time?

e.g. once the guest has inflated/deflated to the target, can we not remember that and assume its not going to change?

This is pretty annoying when you go looking through the logs
Comment 2 Daniel Berrange 2009-05-07 07:04:23 EDT
This is fixed in libvirt upstream 

http://git.et.redhat.com/?p=libvirt.git;a=commit;h=fbd16cecc72494e8a9450f38197221f2f50c9d0e
Comment 3 Cole Robinson 2009-05-07 08:51:54 EDT
The logging issue is fixed, but do we really need to talk to the monitor every time info is called?
Comment 4 Daniel Berrange 2009-05-07 08:57:55 EDT
We have no choice until QEMU is able to provide notifications for thinks like memory balloon changes
Comment 5 Mark McLoughlin 2009-05-22 05:52:23 EDT
Pushing the following to updates-testing:

* Fri May 22 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-10.fc11
- Don't log monitor output to domain log file (bug #499584)
Comment 6 Fedora Update System 2009-05-22 05:53:13 EDT
libvirt-0.6.2-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-10.fc11
Comment 7 Fedora Update System 2009-05-25 17:19:59 EDT
libvirt-0.6.2-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5441
Comment 8 Fedora Update System 2009-05-26 03:57:34 EDT
libvirt-0.6.2-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5515
Comment 9 Mark McLoughlin 2009-05-27 02:42:57 EDT
*** Bug 502681 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2009-06-04 17:21:02 EDT
libvirt-0.6.2-11.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-06-05 09:23:27 EDT
libvirt-0.6.2-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-12.fc11

Note You need to log in before you can comment on or make changes to this bug.