Bug 499614 - System locks up when booting with "intel_iommu=on" (BIOS bug?)
System locks up when booting with "intel_iommu=on" (BIOS bug?)
Status: CLOSED DUPLICATE of bug 490477
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-05-07 08:54 EDT by Rainer Koenig
Modified: 2009-05-14 10:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-05-07 09:17:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Captured kernel messages from the serial console (15.19 KB, text/plain)
2009-05-07 08:54 EDT, Rainer Koenig
no flags Details

  None (edit)
Description Rainer Koenig 2009-05-07 08:54:41 EDT
Created attachment 342832 [details]
Captured kernel messages from the serial console

Description of problem:
When the kernel is booted with bootparam intel_iommu=on the system locks up. 

Version-Release number of selected component (if applicable):

How reproducible:
Always, also with different BIOS settings (e.g. Coherency="on/off")

Steps to Reproduce:
1. Intall F11-Preview
2. Reboot and edit in grub so that boot param intel_iommu=on is submitted
Actual results:
If you boot with params "rhgb quiet" you only see the cursor blinking in the upper left corner of the screen. If you boot without "rhgb quiet" then you see the messages that I captured in the attached file.

Expected results:
System should boot to runlevel 5.

Additional info:
Since the capture log also has a line

DMAR:Unknown DMAR structure type

U expect that the root cause of this bug can be somewhere within the BIOS. So I will contact BIOS development first to see if they can explain that. This is why this bug is currently set to low priority.
Comment 1 Mark McLoughlin 2009-05-07 09:03:21 EDT
Thanks Rainer
Comment 2 David Woodhouse 2009-05-07 09:11:16 EDT
Can you build a kernel without CONFIG_INTR_REMAP to check whether it's DMA remapping or interrupt remapping that's causing the problem?
Comment 3 David Woodhouse 2009-05-07 09:17:10 EDT
User reports that turning off legacy keyboard emulation in the BIOS fixes the hang. This seems to be a duplicate of bug 490477.

User reports an identical hang at 'starting udev', which needs to be investigated further.

*** This bug has been marked as a duplicate of bug 490477 ***

Note You need to log in before you can comment on or make changes to this bug.