Bug 499623 - Error creating Live CD : Could not create snapshot device using: /sbin/dmsetup create imgcreate-8115-5858 --table 0 2097152 snapshot /dev/loop0 /dev/loop1 p 8
Error creating Live CD : Could not create snapshot device using: /sbin/dmsetu...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 09:26 EDT by udo
Modified: 2009-05-07 14:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 14:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2009-05-07 09:26:36 EDT
Description of problem: Error creating Live CD : Could not create snapshot device using: /sbin/dmsetup create imgcreate-8115-5858 --table 0 2097152 snapshot /dev/loop0 /dev/loop1 p 8 when making livecd


Version-Release number of selected component (if applicable):
020.1-1

How reproducible:
`livecd-creator --config=livecd-fedora-minimal.ks` stock kickstart file except selinux disabled


Steps to Reproduce:
1. livecd-creator --config=livecd-fedora-minimal.ks
2.
3.
  
Actual results:
  Installing: perl-version                 ##################### [166/168] 
  Installing: exim                         ##################### [167/168] 
  Installing: perl-Pod-Simple              ##################### [168/168] 

authconfig: Authentication module /lib64/security/pam_fprintd.so is missing. Authentication process will not work correctly.
authconfig: Authentication module /lib64/security/pam_pkcs11.so is missing. Authentication process will not work correctly.
Removing password for user root.
passwd: Success
e2fsck 1.41.4 (27-Jan-2009)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
fedora-minim-x86: 16720/65536 files (0.4% non-contiguous), 127402/262144 blocks
e2fsck 1.41.4 (27-Jan-2009)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
fedora-minim-x86: 16720/32768 files (0.4% non-contiguous), 125216/125216 blocks
device-mapper: reload ioctl failed: Invalid argument
Command failed
Error creating Live CD : Could not create snapshot device using: /sbin/dmsetup create imgcreate-8115-5858 --table 0 2097152 snapshot /dev/loop0 /dev/loop1 p 8


Expected results:
livecd

Additional info:
dm is working quite OK here: lvm on crypto on raid5...
Comment 1 Jeremy Katz 2009-05-07 13:01:40 EDT
What version of livecd-tools and what are you running on your host?
Comment 2 udo 2009-05-07 13:12:25 EDT
$ rpm -qi livecd-tools
Name        : livecd-tools                 Relocations: (not relocatable)
Version     : 020.1                             Vendor: Fedora Project
Release     : 1.fc10                        Build Date: Tue 21 Apr 2009 08:16:34 PM CEST
Install Date: Thu 07 May 2009 02:31:52 PM CEST      Build Host: x86-3.fedora.phx.redhat.com
Group       : System Environment/Base       Source RPM: livecd-tools-020.1-1.fc10.src.rpm
Size        : 415481                           License: GPLv2
Signature   : DSA/SHA1, Thu 30 Apr 2009 01:49:33 PM CEST, Key ID bf226fcc4ebfc273
Packager    : Fedora Project
URL         : http://git.fedoraproject.org/?p=hosted/livecd
Summary     : Tools for building live CD's
(cut)

$ uname -a
Linux surfplank2.hierzo 2.6.29.2 #3 SMP PREEMPT Tue Apr 28 18:41:46 CEST 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Jeremy Katz 2009-05-07 13:45:44 EDT
Do you have the dm-snapshot bits built and loaded into your kernel?  

I suspect if you switch and use the actual Fedora kernel, things will Just Work (tm)
Comment 4 udo 2009-05-07 13:57:46 EDT
This is the _stock_ kernel source with only minimal patches for random poolsize, entropy gathering and k10temp. Nothing related to dm.
As I wrote: dm works great here with lvm on crypto on raid5.
Comment 5 udo 2009-05-07 13:59:13 EDT
No Snapshot target enabled here as I don't use it.
Comment 6 Jeremy Katz 2009-05-07 14:03:12 EDT
(In reply to comment #5)
> No Snapshot target enabled here as I don't use it.  

It's required for building live images.  The error message you're getting is the kernel saying it can't create the snapshot.  And thus, the image build fails.
Comment 7 udo 2009-05-07 14:19:46 EDT
Can you please at least document this requirement? (would have to study the code to understand why we need a snapshot for making a livecd)
And perhaps beautify the error message a bit now that we know the cause?

Note You need to log in before you can comment on or make changes to this bug.