Bug 499654 - failure to add more than 16 virtio-blk devices in virt-manager
failure to add more than 16 virtio-blk devices in virt-manager
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-07 11:06 EDT by Marcelo Tosatti
Modified: 2009-10-07 08:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 08:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcelo Tosatti 2009-05-07 11:06:10 EDT
Description of problem:

virt-manager limits virtio-blk devices to 16.

Version-Release number of selected component (if applicable):

Fedora 11 Preview 

How reproducible:

Always

Steps to Reproduce:
1. Add 16 virtio-block storage devices
2.
3.
  
Actual results:


Unable to complete install: Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/addhardware.py", line 616, in add_storage
    self._dev.generate_target(used)
  File "/usr/lib/python2.6/site-packages/virtinst/VirtualDisk.py", line 925, in generate_target
    raise ValueError(_("No more space for disks of type '%s'" % prefix))
ValueError: No more space for disks of type 'vd'

Expected results:

Fail when QEMU reports failure, there are 32 PCI slots available.


Additional info:
Comment 1 Mark McLoughlin 2009-05-07 11:13:58 EDT
Moving to virtinst, since the code is there
Comment 2 Bug Zapper 2009-06-09 11:20:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Update System 2009-09-13 20:03:48 EDT
python-virtinst-0.400.3-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.3-9.fc11
Comment 4 Fedora Update System 2009-09-15 03:37:16 EDT
python-virtinst-0.400.3-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9548
Comment 5 Fedora Update System 2009-10-06 23:10:34 EDT
python-virtinst-0.400.3-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9548
Comment 6 Cole Robinson 2009-10-07 08:29:42 EDT
This should be fixed by python-virtinst-0.400.3-10.fc11 now in stable. Closing.

Note You need to log in before you can comment on or make changes to this bug.