Bug 499656 - virt-manager Scaling->Always - scales the guest screen up but not down.
virt-manager Scaling->Always - scales the guest screen up but not down.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-07 11:10 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 18:55:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-05-07 11:10:23 EDT
Description of problem:

This may be intentional, but while testing https://fedoraproject.org/wiki/QA:Testcase_Console_Graphics_Scaling it seems that the virt-manager/virt-viewer window correctly scales the guest window when the window size exceeds the guest native resolution.  However when making the guest window smaller, it doesn't scale down with the window size.


Version-Release number of selected component (if applicable):
virt-manager-0.7.0-4.fc11.x86_64

How reproducible:


Steps to Reproduce:
https://fedoraproject.org/wiki/QA:Testcase_Console_Graphics_Scaling
  
Actual results:

virt-manager correctly scales the guest screen up when increasing the window size, but the opposite is not true.  There seems to be a lower bound when scaling down the window.

Expected results:

Free scaling of the window above or below the native resolution of the guest.


Additional info:
Comment 1 Daniel Berrange 2009-05-07 11:47:40 EDT
Virt-manager needs to call vnc_display_set_force_size(FAlse)  to stop GTK-VNC setting a minimum size on the widget. When doing so though, virt-manager needs to be sure to respond to 'vnc-desktop-resize" signals and set its window to a reasonable initial size, otherwise you'll end up with a 1x1 pixel VNC window by default :-)
Comment 2 Bug Zapper 2009-06-09 11:21:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Daniel Berrange 2009-10-16 10:30:58 EDT
Addressing this bug correctly is quite hard, because there's many scenarios to deal with. The virt-viewer app pretty much does it the right way now

http://hg.fedoraproject.org/hg/virt-viewer/file/e05cd5be9c36/src/viewer.c#l1

 1. Scaling is always enabled
 2. Upon vnc-desktop-resize, the top level window is automatically resized to allow entire VNC desktop to be viewed at 1:1 size if possible
 3. If the VNC desktop won't fit on host desktop at 1:1 size, then top level window is resized as large as possible and the VNC desktop scales to fit what's available
 4. If the user manually resizes the top level window, then no further automatic window resizing will be done - the VNC widget will always scale to the user's requested window size.
 5. The VNC widget is placed inside a GtkAlignment, and this is controlled such that the VNC widget always maintains a normal aspect ratio.
Comment 4 Cole Robinson 2009-11-30 07:08:40 EST
Okay, taking some inspiration from Dan's virt-viewer code (and vinagre), I've fixed this upstream, but managed to maintain the disabled scaling option and fixed the scrolled window interaction. Moving to POST.
Comment 5 Cole Robinson 2009-12-03 18:55:29 EST
This would be a bit risky to backport to F11, but it should now be available in rawhide with virt-manager 0.8.1, so closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.