Bug 499661 - Includes/Provides directory it MUST NOT
Includes/Provides directory it MUST NOT
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 11:16 EDT by Michael Schwendt
Modified: 2009-05-07 17:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 17:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-05-07 11:16:11 EDT
$ rpmls -p freetype-devel-2.3.9-3.fc11.x86_64.rpm|grep pkg|grep ^d
drwxr-xr-x  /usr/lib64/pkgconfig

Your package must not include this directory, because this directory belongs
into the pkgconfig package(s). This hides broken dependencies in other
packages, which expect to pull in pkgconfig by depending on
%{_libdir}/pkgconfig.

Note: I haven't checked whether the ownership of directories other than
%_libdir/pkgconfig is correct.
Comment 1 Matthias Clasen 2009-05-07 17:33:20 EDT
Fixed in devel, not sure its really worth an update. I've put it in F-11 cvs anyway, so it'll show up when we do an update.

Note You need to log in before you can comment on or make changes to this bug.