This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 499666 - Reboot fails when using qemu -kernel
Reboot fails when using qemu -kernel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-07 11:23 EDT by Daire Byrne
Modified: 2009-05-19 20:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.10.4-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 20:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daire Byrne 2009-05-07 11:23:30 EDT
Description of problem:
When you define a kernel and initrd line in a libvirt XML (for example) the VM boots normally but hangs on the BIOS after a reboot.

Version-Release number of selected component (if applicable):
[root@sys422 ~]# rpm -qa | grep qemu
qemu-img-0.10-15.fc11.x86_64
qemu-common-0.10-15.fc11.x86_64
qemu-system-x86-0.10-15.fc11.x86_64

[root@sys422 ~]# rpm -qa | grep libvirt
libvirt-python-0.6.2-3.fc11.x86_64
libvirt-0.6.2-3.fc11.x86_64

How reproducible:
Always. Define a kernel and initrd to boot and set boot device to HD (use a blank image). Once booted reboot the VM and watch it hang on the BIOS.

Steps to Reproduce:
1. Define a kernel and initrd to boot and set boot device to HD (use a blank image). In my case the kernel and initrd are on an NFS filesystem.
2. Reboot and the VM hangs at the BIOS.
3.
  
Actual results:
VM hangs on reboot.

Expected results:
Should just work the same as if the kernel and initrd are being loaded within the VM by Grub.

Additional info:
There used to be a dump captured in the /var/log/libvirt/qemu logs in Fedora10 but since upgrading to Fedora11/Rawhide it doesn't write anything useful.

This issue has been present from Fedora9->11 but now I'm finally getting around to reporting it!
Comment 1 Mark McLoughlin 2009-05-07 11:42:45 EDT
(In reply to comment #0)

> There used to be a dump captured in the /var/log/libvirt/qemu logs in Fedora10
> but since upgrading to Fedora11/Rawhide it doesn't write anything useful.

Could you just include the qemu command line from the log?
Comment 2 Daire Byrne 2009-05-07 12:02:36 EDT
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin HOME=/root USER=root LOGNAME=root /usr/bin/qemu-kvm -S -M pc -m 5408 -smp 2 -name fedora11 -uuid 0ada0896-4135-45f9-bd10-247a628c2fc5 -monitor pty -pidfile /var/run/libvirt/qemu//fedora11.pid -boot c -kernel /nfs/gps0/mnt/raid1/gps-master/sysimages/fedora11_64/boot/vmlinuz-current -initrd /nfs/gps0/mnt/raid1/gps-master/sysimages/fedora11_64/boot/initrd-diskless.img -append init=/init ramdisk_size=65536 root=/dev/ram0 rw FSCFC_IMAGE=fedora11_64 fscache -drive file=/mnt/images1/fedora11.qcow2,if=virtio,index=0,boot=on -net nic,macaddr=00:16:36:10:64:68,vlan=0,model=virtio -net tap,fd=17,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 -k en-gb
char device redirected to /dev/pts/8
char device redirected to /dev/pts/13
qemu: loading initrd (0x408ed5 bytes) at 0x000000007fbf7000
info cpus
* CPU #0: pc=0x00000000000ffff0 thread_id=29015
  CPU #1: pc=0x00000000000ffff0 thread_id=29016
cont
balloon 5238
info balloon
balloon: actual=5408
..
..
Comment 3 Glauber Costa 2009-05-07 12:52:22 EDT
it probably does not store the boot information for the next round.
So the next time it boots, qemu will probably try to boot from the disk, as it was never ever requested to boot from the -kernel parameter.
Comment 4 Fedora Admin XMLRPC Client 2009-05-07 13:58:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Mark McLoughlin 2009-05-11 05:58:43 EDT
Glauber's fix upstream:

  http://lists.gnu.org/archive/html/qemu-devel/2009-05/msg00425.html
Comment 6 Daire Byrne 2009-05-11 10:52:17 EDT
Mark,

(In reply to comment #5)
> Glauber's fix upstream:
> 
>   http://lists.gnu.org/archive/html/qemu-devel/2009-05/msg00425.html  

Cheers. Looks like a few things have changed in the code since the last fc11 RPM so it is not a simple patch for me to backport. Any chance of a patch against the fedora version of the RPMS so that I can test it?
Comment 7 Glauber Costa 2009-05-12 09:14:49 EDT
I will provide a patch myself as soon it is accepted upstream.
Comment 8 Fedora Update System 2009-05-12 10:48:55 EDT
qemu-0.10-18.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10-18.fc11
Comment 9 Glauber Costa 2009-05-12 10:49:24 EDT
please test and karma it.
Comment 10 Daire Byrne 2009-05-12 11:06:26 EDT
(In reply to comment #9)
> please test and karma it.  

Works for me. Thanks!
Comment 11 Mark McLoughlin 2009-05-12 11:30:09 EDT
Glauber built this fix, it will appear as an F-11 update:

https://koji.fedoraproject.org/koji/buildinfo?buildID=101869

* Tue May 12 2009 Glauber Costa <glommer@redhat.com> - 2:0.10-17
- fix reboot with -kernel parameter
Comment 12 Mark McLoughlin 2009-05-12 11:40:23 EDT
(Nevermind my comment :-)
Comment 13 Fedora Update System 2009-05-12 20:25:54 EDT
qemu-0.10-18.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4890
Comment 14 Fedora Update System 2009-05-13 05:20:08 EDT
qemu-0.10.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-1.fc11
Comment 15 Fedora Update System 2009-05-13 07:58:58 EDT
qemu-0.10.4-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-2.fc11
Comment 16 Mark McLoughlin 2009-05-13 08:12:30 EDT
Daire, could you re-test with qemu-0.10.4-2.fc11 ? add your comments here:

  https://admin.fedoraproject.org/updates/qemu-0.10.4-2.fc11
Comment 17 Fedora Update System 2009-05-13 11:06:54 EDT
qemu-0.10.4-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-3.fc11
Comment 18 Fedora Update System 2009-05-13 22:56:23 EDT
qemu-0.10.4-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4954
Comment 19 Fedora Update System 2009-05-14 07:33:35 EDT
qemu-0.10.4-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-4.fc11
Comment 20 Fedora Update System 2009-05-15 19:35:30 EDT
qemu-0.10.4-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5050
Comment 21 Fedora Update System 2009-05-18 23:36:55 EDT
qemu-0.10.4-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-5.fc11
Comment 22 Fedora Update System 2009-05-19 20:52:42 EDT
qemu-0.10.4-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.