Bug 499682 - DM Multipath Documentation Should Include Recommended Configuration Settings
DM Multipath Documentation Should Include Recommended Configuration Settings
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 12:29 EDT by Scott Mayhew
Modified: 2009-08-19 23:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 14:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Mayhew 2009-05-07 12:29:47 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009032713 Fedora/3.0.8-1.fc10 Firefox/3.0.8

The DM Multipath Documentation [Book identifier: DM_Multipath(EN)-5 (2009-01-06T15:35)] should include recommended configuration settings.  Currently, we ship a file called multipath.conf.defaults in the documentation that comes with the device-mapper-multipath package.  That file lists default settings for various vendors' SAN hardware, with no explanation of where those settings originated.  The DM_Multipath book should include these settings, along with an explanation of where these settings came from (directly from the vendor?).  Furthermore, if the recommended settings are different for clustered versus non-clustered environments, then the documentation should explicitly state what those differences are. 

Reproducible: Always
Comment 2 Steven J. Levine 2009-06-25 15:23:23 EDT
Adding Ben Marzinski to the CC list for this bug, since I rely on him for pretty much all the multipath information. I have sent Ben a note (6/25/09) asking him to look at this bug and asking him to help me figure out how to respond.
Comment 3 Ben Marzinski 2009-06-30 17:01:01 EDT
The defaults come from vendors.  They are the same for clustered and non-clustered environments, and they aren't just recommendations. They are the compiled in default configuration.  That means that unless users want to change them, they don't have to do anything.  Multipath will automatically use these configuration values.  Also, as new features are added multipath, and new hardware devices are released, these configurations change.  Unless we want to update them in the DM_Multipath book every release, it makes more sense to point users to that file, which will have the latest configuration.
Comment 4 Steven J. Levine 2009-08-07 14:38:31 EDT
As per Ben's commnt in #3, above, I'm closing this bug. I debated whether to categorize this as NOTABUG or WONTFIX, but I went with NOTABUG for now.

Note You need to log in before you can comment on or make changes to this bug.