Bug 499704 - VM migration fails with "TCP migration is not supported with this QEMU binary"
VM migration fails with "TCP migration is not supported with this QEMU binary"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
high Severity urgent
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-07 14:04 EDT by Mike Hinz
Modified: 2009-07-05 10:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 12:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log output from libvirtd after a couple of failed attempt to do a VM migration to this target machine (487 bytes, text/plain)
2009-05-07 14:50 EDT, Mike Hinz
no flags Details
cpu info from hardware (2.86 KB, text/plain)
2009-05-07 14:57 EDT, Mike Hinz
no flags Details
lspci info (21.32 KB, text/plain)
2009-05-07 14:58 EDT, Mike Hinz
no flags Details
virsh capabilities output (2.28 KB, text/plain)
2009-05-07 15:00 EDT, Mike Hinz
no flags Details

  None (edit)
Description Mike Hinz 2009-05-07 14:04:37 EDT
Description of problem:

Attempting to migrate a running or stopped VM fails in all cases.  

Version-Release number of selected component (if applicable):

virsh # version
Compiled against library: libvir 0.6.2
Using library: libvir 0.6.2
Using API: QEMU 0.6.2
Running hypervisor: QEMU 0.10.1

[root@vmh2 Download]# uname -a
Linux vmh2 2.6.29.1-111.fc11.x86_64 #1 SMP Fri Apr 24 10:57:09 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:

Always

Steps to Reproduce:
1.  Connect to the local machine's hypervisor as follows and see the local machines:

virsh # connect qemu:///system

virsh # list --all
 Id Name                 State
----------------------------------
  3 vm1                  running
  - vm2                  shut off


2.  Verify connectivity to the hypervisor of the remote target system as follows:

virsh # connect qemu+tcp://vmh3/system

virsh # uri
qemu+tcp://vmh3/system

virsh # list --all
 Id Name                 State
----------------------------------
  4 vm1-vmh3             running



3.  Attempt the migration as follows:

virsh # connect qemu:///system

virsh # migrate vm2 qemu+tcp://vmh3/system vm5
error: invalid argument in only tcp URIs are supported for KVM migrations

virsh # migrate vm2 qemu+tcp://vmh3/system
error: operation failed: failed to start listening VM

Above shows first successful connect to the local hypervisor and then failure to migrate with two slightly different syntax to the remote hypervisor even though step 2 above clearly shows that we can 100% connect to the remote hypevisor.  

We can demonstrate this same failure with the transport method of tcp, ssh, or tls.  
  
Actual results:

The operation fails and throws errors depending upon the exact command line.  The error messages are as follows:

virsh # migrate --live vm1 qemu+tcp://vmh3/system
error: operation failed: failed to start listening VM

or 

virsh # migrate --live vm1 qemu+tcp://vmh3/system vm5
error: invalid argument in only tcp URIs are supported for KVM migrations

Expected results:

The VM migration should start and succeed for either stopped or running VMs

Additional info:

This is in a lab environment with all firewalls and selinux disabled on all physical machines.  Connectivity always succeed via tcp method, ssh method, and tls method.  However, migration always fails regardless of the connectivity method attempted.
Comment 1 Mark McLoughlin 2009-05-07 14:15:05 EDT
Wrt:

  error: operation failed: failed to start listening VM

could you attach the logfile from /var/log/libvirt/qemu for the listening VM?
Comment 2 Mike Hinz 2009-05-07 14:50:32 EDT
Created attachment 342913 [details]
Log output from libvirtd after a couple of failed attempt to do a VM migration to this target machine

This was requested as per the devs.  Enabled logging at level 0 to a file in libvirtd.conf and then ran the tests that failed.  These are essentially the same errors that are seen at the local machine hypervisor.
Comment 3 Mike Hinz 2009-05-07 14:55:20 EDT
The virt bug reporting wiki asks for exact machine and version info please see the below:

[root@vmh2 CA]# rpm -q kvm python-virtinst virt-viewer virt-manager
package kvm is not installed
python-virtinst-0.400.3-7.fc11.noarch
virt-viewer-0.0.3-4.fc11.x86_64
virt-manager-0.7.0-4.fc11.x86_64
[root@vmh2 CA]#

[root@vmh2 CA]# uname -a
Linux vmh2 2.6.29.1-111.fc11.x86_64 #1 SMP Fri Apr 24 10:57:09 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 4 Mike Hinz 2009-05-07 14:57:11 EDT
Created attachment 342915 [details]
cpu info from hardware

Added as per virtualization bug reporting wiki.
Comment 5 Mike Hinz 2009-05-07 14:58:24 EDT
Created attachment 342918 [details]
lspci info

Added as per request from virtualization bug reporting wiki
Comment 6 Mike Hinz 2009-05-07 15:00:10 EDT
Created attachment 342919 [details]
virsh capabilities output

Output of virsh capabilities as per virtualization bug reporting wiki.
Comment 7 Mark McLoughlin 2009-05-07 15:01:30 EDT
error : this function is not supported by the hypervisor: TCP migration is not supported with this QEMU binary


Ah, we need this:

http://www.redhat.com/archives/libvir-list/2009-April/msg00567.html
Comment 8 Mark McLoughlin 2009-05-07 15:12:20 EDT
Building

https://koji.fedoraproject.org/koji/taskinfo?taskID=1341067

* Thu May  7 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-7.fc11
- Enable migration for qemu 0.10 (bug #499704)
Comment 9 Mark McLoughlin 2009-05-07 16:47:09 EDT
No
Comment 10 Daire Byrne 2009-06-03 11:54:43 EDT
FYI

Migration now works for me using virsh with the latest packages but I still get the "TCP migration is not supported" error when using virt-manager's "migrate" menu option. Is that expected or known?
Comment 11 Mark McLoughlin 2009-06-03 12:36:23 EDT
Thanks for testing Daire

(In reply to comment #10)

> Migration now works for me using virsh with the latest packages but I still get
> the "TCP migration is not supported" error when using virt-manager's "migrate"
> menu option. Is that expected or known?  

I'm not actually sure, off hand - even if it is known, it should be in bugzilla, though. Please do file a bug

Closing this now, libvirt-0.6.2-8.fc11 is in F11 final

Note You need to log in before you can comment on or make changes to this bug.