Bug 499705 - when running large cvs checkouts on x86_64 kvm of F-11 beta, glibc causes segfault
when running large cvs checkouts on x86_64 kvm of F-11 beta, glibc causes seg...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 14:08 EDT by Paul Wouters
Modified: 2009-05-11 19:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 19:39:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb full, but with client name replaced with XXXXX (same length) (14.01 KB, text/plain)
2009-05-07 14:08 EDT, Paul Wouters
no flags Details

  None (edit)
Description Paul Wouters 2009-05-07 14:08:47 EDT
Created attachment 342904 [details]
gdb full, but with client name replaced with XXXXX (same length)

Description of problem:
cvs[9286]: segfault at 0 ip 0000003660a81706 sp 00007fff351df638 error 4 in libc-2.9.90.so[3660a00000+167000]


Version-Release number of selected component (if applicable):

cvs-1.11.23-4.fc11.x86_64
glibc-2.9.90-22.x86_64
kernel-2.6.29.2-126.fc11.x86_64

How reproducible:
Create a large cvs repo and check it out locally or via ssh works for me everytime. not sure how reproducable this is for others.

Steps to Reproduce:
1. cvs upd

Actual results:
Program received signal SIGSEGV, Segmentation fault.
memchr () at ../sysdeps/x86_64/memchr.S:31
31		movdqa	(%rdi), %xmm0
Current language:  auto; currently asm
Comment 1 Jakub Jelinek 2009-05-11 19:39:09 EDT
Fixed in glibc-2.10.1 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.