Bug 499720 - Smb4k is installed, but not its dependencies (KDE)
Smb4k is installed, but not its dependencies (KDE)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smb4k (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 15:19 EDT by Penelope Fudd
Modified: 2009-11-05 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.10.4-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 19:06:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2009-05-07 15:19:24 EDT
Description of problem:
Installed Fedora 10, found smb4k in menu, attempted to run it.  Complains that kdesu isn't installed.

Version-Release number of selected component (if applicable):
smb4k-0.10.2-1.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1. rpm -Uvh smb4k
2. log in as regular user
3. Applications/Internet/Smb4k
  
Actual results:
Either your PATH environment variable is not set properly or there are the following programs missing on your system:
kdesu
Please correct this and restart Smb4K.

Expected results:
Either work, or not show up on menu

Additional info:
Comment 1 Marcin Garski 2009-05-10 10:47:28 EDT
Could you execute following command and paste their output?

rpm -q kdebase-runtime
which kdesu
Comment 2 Penelope Fudd 2009-05-10 11:18:10 EDT
rpm -q kdebase-runtime
package kdebase-runtime is not installed


which kdesu
/usr/bin/which: no kdesu in (/home/croot/bin:/home/croot/bin/LINUX:/home/croot/pubbin/LINUX:/usr/depot/ccache-2.2/mybin:/usr/depot/distcc/mybin:/usr/local/bin:/bin:/usr/local/etc:/usr/sbin:/usr/ucb:/sbin:/usr/5bin:/usr/X11/bin:/usr/bin:/usr/bin/X11:/usr/bsd:/usr/ccs/bin:/usr/etc:/usr/games:/usr/lib:/usr/libexec:/usr/X11R6/bin:/usr/local/sbin:.)

rpm -q --requires smb4k
/bin/sh  
/bin/sh  
/bin/sh  
libQtCore.so.4  
libQtDBus.so.4  
libQtGui.so.4  
libQtNetwork.so.4  
libQtSvg.so.4  
libQtXml.so.4  
libc.so.6  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.3)  
libc.so.6(GLIBC_2.2)  
libc.so.6(GLIBC_2.4)  
libgcc_s.so.1  
libkdecore.so.5  
libkdeui.so.5  
libkio.so.5  
libkparts.so.4  
libm.so.6  
libm.so.6(GLIBC_2.0)  
libpthread.so.0  
libpthread.so.0(GLIBC_2.0)  
libsmb4kcore.so.3  
libsmb4kdialogs.so  
libstdc++.so.6  
libstdc++.so.6(CXXABI_1.3)  
libstdc++.so.6(GLIBCXX_3.4)  
libstdc++.so.6(GLIBCXX_3.4.9)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
samba-client  

# I think kdebase-runtime or /usr/bin/kdesu should be added to the list of requirements.
Comment 3 Fedora Update System 2009-10-24 07:16:53 EDT
smb4k-0.10.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/smb4k-0.10.4-1.fc11
Comment 4 Fedora Update System 2009-10-24 07:17:40 EDT
smb4k-0.10.4-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/smb4k-0.10.4-1.fc10
Comment 5 Marcin Garski 2009-10-24 07:20:23 EDT
Thanks for your replay, sorry for such long delay in bug fixing. Could you test if this is resolved in smb4k-0.10.4-1 release (when it hit testing repo)?
Comment 6 Penelope Fudd 2009-10-25 05:10:40 EDT
Not really; I stumbled across it by accident one day, and thought I'd report it.  It's not something I'd be able to test easily now, due to my time constraints.
Comment 7 Fedora Update System 2009-10-27 02:37:25 EDT
smb4k-0.10.4-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smb4k'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10739
Comment 8 Fedora Update System 2009-10-27 02:48:15 EDT
smb4k-0.10.4-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smb4k'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10770
Comment 9 Fedora Update System 2009-11-05 19:06:05 EST
smb4k-0.10.4-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-11-05 19:06:41 EST
smb4k-0.10.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.