Bug 499723 - Pass port number as number during redirect
Pass port number as number during redirect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
urgent Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Jan Pazdziora
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-05-07 15:32 EDT by Clifford Perry
Modified: 2009-09-10 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: proxy-akamai
Environment:
Last Closed: 2009-09-10 10:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Clifford Perry 2009-05-07 15:35:06 EDT
So right now, for Sat 530 the RHN Proxy code should have only:

http://git.fedorahosted.org/git/?p=spacewalk.git;a=commitdiff;h=f8b7351ca077bf64df4ef54783e16dfa3e5947f4

diff --git a/proxy/proxy/rhnShared.py b/proxy/proxy/rhnShared.py
index 3a3701f..2ab73aa 100644 (file)

--- a/proxy/proxy/rhnShared.py
+++ b/proxy/proxy/rhnShared.py

@@ -169,8 +169,8 @@ class SharedHandler:
     def _parse_url(self, url):
         # Returns scheme, host, port, path
         scheme, netloc, path, params, query, frag = rhnLib.parseUrl(url)
-        host, port = urllib.splitport(netloc)
-        if not port:
+        host, port = urllib.splitnport(netloc)
+        if (port <= 0):
             port = None
         return scheme, host, port, path

This bug which is aligned to 530 is to track that code fix. Not sure if Mirek can provide a sane test plan to test this bit of code out or not. Leaving in modified state for his review before moving to ON_QA. 

Cliff
Comment 2 Miroslav Suchý 2009-05-11 11:44:34 EDT
Test plan... The difference is only that the port is numeric type  (previously text type, which failed later).
So downloading package without error should be ok.
Comment 3 Miroslav Suchý 2009-06-25 07:19:57 EDT
Just for record. I discovered code which check if follow-redirects=2, since we bumped up the number in master, it will not work. I changed to accept 2 and higher.
Commit 27f205f32c13a1d63e033b23f8bb6701e0609f96
It only affect Spacewalk, therefore not needed to wait for another iso.
Comment 5 Jan Pazdziora 2009-07-03 04:33:45 EDT
I used wireshark on the RHN Proxy, used non-SSL for both client -> proxy and proxy -> satellite communication. The x-rhn-transport-capability is follow-redirects=2 for both client -> proxy and proxy -> satellite POST /XMLRPC requests.

So, if this bugzilla is primarily about *not* sending follow-redirects=3, then it passes QA. Mirek, can you confirm and update the summary/title of this bugzilla?

The RHN Proxy version I used was:

# rpm -qa | grep proxy | sort
rhn-proxy-branding-5.3.0.24-1.el5sat
spacewalk-proxy-broker-0.5.7-7.el5sat
spacewalk-proxy-common-0.5.7-7.el5sat
spacewalk-proxy-docs-0.4.1-2.el5sat
spacewalk-proxy-installer-0.5.25-13.el5sat
spacewalk-proxy-management-0.5.7-7.el5sat
spacewalk-proxy-monitoring-0.4.4-3.el5sat
spacewalk-proxy-package-manager-0.5.7-7.el5sat
spacewalk-proxy-redirect-0.5.7-7.el5sat
spacewalk-proxy-selinux-0.5.2-6.el5sat
Comment 6 Miroslav Suchý 2009-07-07 05:01:35 EDT
I changed summary. 
Since everything what was changed is only the change in #1.
Comment 8 Brandon Perkins 2009-09-10 10:38:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.