Bug 499726 - notification-daemon crashes
notification-daemon crashes
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 15:36 EDT by John Cox
Modified: 2009-05-26 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 10:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug-buddy.txt (408.46 KB, text/plain)
2009-05-07 15:36 EDT, John Cox
no flags Details

  None (edit)
Description John Cox 2009-05-07 15:36:19 EDT
Created attachment 342926 [details]
bug-buddy.txt

Description of problem:
I get this when network manager connects my wireless.
I never see the notification, just bug-buddy dialog
** notification-daemon **: cr_parser_new_from_buf: assertion `a_buf && a_len' failed

Version-Release number of selected component (if applicable):

fedora 11 RC
How reproducible:
connect

Steps to Reproduce:
1.enable wireless connection
2.
3.
  
Actual results:
wireless connects and bug-buddy dialog appears

Expected results:
notification should appear

Additional info:
Comment 1 Matthias Clasen 2009-05-07 16:52:38 EDT
The warning comes from libcroco, so it probably happens when librsvg2 passes a bad css statement to libcroco. 

What theme (in particular, what icon theme, are you using when this happens.

Also, it may be worth trying a different theme to see if the notification appears.
If it does, it would be very valuable to learn what icon it contains.

Finally, if you could install debuginfo for notification-daemon get a stacktrace with gdb, that would be great. See http://fedoraproject.org/wiki/StackTraces for some information on how to do that.
Comment 2 John Cox 2009-05-08 10:13:13 EDT
The culprit seems to be the icon theme called Meliae-white which I obtained from gnome-look.org.
Using the default theme with no problems.
Thanks for your help.
Comment 3 Matthias Clasen 2009-05-08 10:21:15 EDT
ok, not much we can do that, I fear. 
If you can identify the offending image, you could investigate whether it is a case of bad svg or a bug in librsvg2. I guess it is a librsvg bug of some sort anyway, since image libraries need to cope with bad input.
Comment 4 Sertaç Ö. Yıldız 2009-05-26 11:29:35 EDT
The problem is due to nm-device-wireless.svg of the icon theme.
Converting it to a png with gimp works. But librsvg cannot cope with it.

Note You need to log in before you can comment on or make changes to this bug.