Bug 499747 - Fedora11 crashes before login, after update (10.93)
Fedora11 crashes before login, after update (10.93)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 18:03 EDT by pat81
Modified: 2015-01-14 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 23:35:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pat81 2009-05-07 18:03:31 EDT
Description of problem:
Fedora crashes at the end of the boot sequence (or 'Plymouth' bar), when trying to display login screen. The screen flashes between blacks (a plain black and a 'trying X' black). The screen gives up flashing after one minute, and is crashed (no cursor/prompt, no ctrl+alt+Fx to another prompt, no ctrl+alt+delete).

This consistently happens after updating F11preview-Gnome with the first batch of online updates. ie going from 10.92 to 10.93.

Version-Release number of selected component (if applicable):
NA

How reproducible:
Unsure
I have 9600GT card (official driver not installed, nothing but the general F11 updates)


Steps to Reproduce:
1. Install liveCD Fedora11Preview-x86_64
2. Install all updates (Sorry I didn't note them)
3. Restart with new kernel, (possibly twice)

Actual results:
Crash before login screen

Expected results:
NA

Additional info:
Comment 1 Matthias Clasen 2009-05-07 20:38:38 EDT
Does booting in runlevel 3 and starting X manually work ?
Comment 2 Bug Zapper 2009-06-09 11:24:54 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Wolfram Wagner 2009-06-17 12:35:37 EDT
Yes, you can boot to other runlevels. Only in 5 X server segfaults almost at the end of its work. Result is that X is not responding. Shutdown via power button acpi and reboot to 3 makes it running again.
I have a nvidia G9600GT, running livnas kmod-nvidia. I tried akmod-nvidia too=> no help. Seems to be in X code, maybe it is not matching together. The came on Jun 16. Before I was running Fed 11 preview without any problems of that kind.
Please ask, if I can be of help!
Comment 4 Wolfram Wagner 2009-06-17 12:38:49 EDT
Last action in Xorg.0.log is 
(II) LoadModule "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/nvidia/libglx.so

Backtrace:
<here it ends>
Comment 5 Wolfram Wagner 2009-06-17 14:49:23 EDT
Found it, sorry it was not a fault of X or nvidia: It was qt that was not completely installed (for some reason) ldconfig returned messages that files where incomplete.
A rpm -qf (file) gave me the packages qt-devel and qt-x11. So I reinstalled them via yum reinstall... 
So for me this is closed...

Note You need to log in before you can comment on or make changes to this bug.