Bug 499792 - xorg.conf confiuration section for synaptics no longer used with xorg-x11-drv-synaptics-1.1.0-5
xorg.conf confiuration section for synaptics no longer used with xorg-x11-drv...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11XorgBlocker
  Show dependency treegraph
 
Reported: 2009-05-08 04:05 EDT by kakashizilla
Modified: 2009-08-17 01:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.0-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 18:46:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log files (40.00 KB, application/x-tar)
2009-05-16 03:04 EDT, kakashizilla
no flags Details
Xorg.log relative to synaptics...-4 (12.20 KB, text/plain)
2009-05-18 15:20 EDT, kakashizilla
no flags Details
/proc/bus/input/devices relative to synaptics...-4 (2.32 KB, text/plain)
2009-05-18 15:22 EDT, kakashizilla
no flags Details

  None (edit)
Description kakashizilla 2009-05-08 04:05:01 EDT
Description of problem:
After the update of xorg-x11-drv-synaptics from 1.1.0-3 to 1.1.0-5,
xorg no longer use the configuration written in xorg.conf, and use the autoprobe "default pointer" mouse driver instead of synaptics driver.

 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Add a configuration section in xorg.conf for the corepointer to use the synaptics driver, with options like <"RTCornerButton" "2">
2.Run xorg with version 1.1.0-3 of the driver : OK
3.Run xorg with version 1.1.0-5 of the driver : synaptics is not used
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2009-05-10 21:06:38 EDT
xorg-x11-server-1.6.1-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.6.1-14.fc11
Comment 2 Fedora Update System 2009-05-12 00:00:52 EDT
xorg-x11-server-1.6.1-14.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4764
Comment 3 Sergio Monteiro Basto 2009-05-13 12:38:48 EDT
please See https://fedoraproject.org/wiki/Input_device_configuration
Comment 4 Peter Hutterer 2009-05-13 19:10:21 EDT
Please give the package listed in Comment #2 a test. It should resolve your issue.
Comment 5 kakashizilla 2009-05-14 14:34:23 EDT
Sorry for the delay.
the package 'xorg-x11-server' cannot be found by yum. I have tryed 'xorg-x11-server-Xorg-1.6.1-14' instead.
This package does not solve the problem. It is worst : after the installation, there was no mouse at all !
But the old xorg-x11-drv-synaptics-1.1.0-3 driver works with it.
Comment 6 Peter Hutterer 2009-05-14 20:09:28 EDT
Please try the scratch package below, it contains another fix for this issue.
The previous fix enabled "synaptics" to be a mouse driver (and X didn't synthesize a mouse section anymore) but if that driver was not referenced by the ServerLayout, you'd end up with no devices.

This scratch build addresses this issue, and a synaptics InputDevice section in the xorg.conf is referenced automatically (if no pointer devices are referenced in the serverlayout).

http://koji.fedoraproject.org/koji/taskinfo?taskID=1355493
Comment 7 kakashizilla 2009-05-15 15:12:14 EDT
I have tried xorg-x11-server-Xorg-1.6.1-15, but without more success: the touchpad is still unusable.
A point that I don't understand : the problem is not in the driver xorg-x11-drv-synaptics ??? What has changed since everything works with version 1.1.0-3, and not with 1.1.0-5 ?

PS: my touchpad is referenced in the ServerLayout, and is define with the option CorePointer.
There is the option 
      "AllowEmptyInput" "off",
so why does the server (versions 14 & 15) start if the pointer is not available ?

Thanks
Comment 8 Peter Hutterer 2009-05-16 00:36:44 EDT
Please attach your Xorg.log file and your xorg.conf.

You've stumbled across a bug in the server, but it seems that's not what triggered the issues you see.

-5 disabled the second synaptics device, i.e. if you have a synaptics device configured in the xorg.conf and one added by HAL, then the second one won't be added. All the configuration options of the xorg.conf should still apply though.

> PS: my touchpad is referenced in the ServerLayout, and is define with the
> option CorePointer.
> There is the option 
>       "AllowEmptyInput" "off",
> so why does the server (versions 14 & 15) start if the pointer is not available

I don't quite know what you want to achieve by AEI off (since I haven't seen your xorg.conf) but there's a high chance it doesn't do what you think it does.
AEI off means that if there's no core pointer device, then the server generates one ("default pointer"). This is what the two scratch builds address. 

AEI off does not prohibit the server from starting. Since server 1.4, there's always a (virtual) core pointer device.
Comment 9 kakashizilla 2009-05-16 03:04:05 EDT
Created attachment 344258 [details]
log files
Comment 10 kakashizilla 2009-05-16 03:05:42 EDT
Thank you for your explanation, I think I begin to understand.
I have attached my Xorg.conf, and two versions of Xorg.log : one obtained with
synaptics...-3, and the other with -5.
A diff point out the problem (I suppose) : with -5, the x-axis range, y-axis
range and the buttons are not defined.
Comment 11 Peter Hutterer 2009-05-17 17:15:20 EDT
oh. this is weird. in -5 the driver doesn't get the axis range, hence it doesn't detect any movement.
can you please give http://koji.fedoraproject.org/koji/buildinfo?buildID=100856 a try so I can narrow down which patch broke it?

when you downgrade to -4, please attach your Xorg.log and /proc/bus/input/devices (as separate files, not tarballs please)
Comment 12 kakashizilla 2009-05-18 15:18:31 EDT
Good. Everything works with synaptics...-4 and xorg...-15.
I attach below the two files.
Comment 13 kakashizilla 2009-05-18 15:20:52 EDT
Created attachment 344507 [details]
Xorg.log relative to synaptics...-4
Comment 14 kakashizilla 2009-05-18 15:22:39 EDT
Created attachment 344508 [details]
/proc/bus/input/devices relative to synaptics...-4
Comment 15 Fedora Update System 2009-05-18 19:26:44 EDT
xorg-x11-drv-synaptics-1.1.0-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.1.0-7.fc11
Comment 16 Peter Hutterer 2009-05-18 19:30:25 EDT
I found it. Cause of the issue was an incorrect return value introduced in -5 that can be triggered if there is an xorg.conf with a synaptics touchpad and a mouse is opened before the synaptics device when running through /dev/input/event*.

Please install synaptics 1.1.0-7 and that should fix the issue.
Comment 17 kakashizilla 2009-05-19 15:05:32 EDT
Very good work ! Everything is OK with synaptics...-7
Thanks for all !
Farewell
Comment 18 Peter Hutterer 2009-05-19 18:46:55 EDT
Thanks for testing. Closing as fixed in version xorg-drv-synaptics-1.1.0-7.

Marking this bug as F11 blocker though, this should go in for final.
Comment 19 Fedora Update System 2009-05-20 19:56:11 EDT
xorg-x11-drv-synaptics-1.1.0-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2009-05-24 20:20:14 EDT
xorg-x11-server-1.6.1.901-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.6.1.901-2.fc11
Comment 21 Peter Hutterer 2009-05-24 20:23:36 EDT
Just a note regarding Comment #20. This fixes what I thought was the cause for this bug until comment #8.

If a synaptics InputDevice section is not referenced from the server layout, the server would initialise a default mouse device. This is fixed now.
Comment 22 Fedora Update System 2009-07-08 18:29:56 EDT
xorg-x11-server-1.6.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.6.2-1.fc11
Comment 23 Fedora Update System 2009-07-28 19:29:57 EDT
xorg-x11-server-1.6.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.6.2-3.fc11
Comment 24 Fedora Update System 2009-08-13 18:11:59 EDT
xorg-x11-server-1.6.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.6.3-2.fc11
Comment 25 Fedora Update System 2009-08-17 01:02:51 EDT
xorg-x11-server-1.6.3-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.6.3-3.fc11

Note You need to log in before you can comment on or make changes to this bug.