Bug 499831 - default volume too low on Toshiba Satellite Pro P200 [HDA Intel 1179:ff00]
default volume too low on Toshiba Satellite Pro P200 [HDA Intel 1179:ff00]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-05-08 09:44 EDT by Chris Tyler
Modified: 2009-05-21 11:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 05:07:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of alsa-info.sh (23.80 KB, text/plain)
2009-05-08 09:44 EDT, Chris Tyler
no flags Details
mixer values before fix (2.18 KB, text/plain)
2009-05-08 09:45 EDT, Chris Tyler
no flags Details
settings after adjusting 'front' to 100% (2.18 KB, text/plain)
2009-05-08 09:45 EDT, Chris Tyler
no flags Details
output of lshw (27.87 KB, text/plain)
2009-05-08 09:46 EDT, Chris Tyler
no flags Details

  None (edit)
Description Chris Tyler 2009-05-08 09:44:09 EDT
Created attachment 343080 [details]
output of alsa-info.sh

Description of problem:
The default audio levels on this laptop are barely audible. The hardware volume scrollwheel (which causes the OSD volume control to appear), volume control applet, and pavucontrol are all incapable of setting the volume to a sufficiently high level -- it's necessary to use alsamixer to set the 'front' control to 100%.

Version-Release number of selected component (if applicable):
 alsa-utils-1.0.19-4.fc11.x86_64
 alsa-lib-1.0.19-3.fc11.x86_64
 alsa-plugins-pulseaudio-1.0.18-3.fc11.x86_64

 kernel-2.6.29.2-126.fc11.x86_64

 pulseaudio-utils-0.9.15-11.fc11.x86_64
 pulseaudio-libs-0.9.15-11.fc11.x86_64
 pulseaudio-0.9.15-11.fc11.x86_64

Steps to Reproduce:
1. Install F11 preview, update to rawhide, observe that sound is too quiet.
2. Use alsamixer to set 'front' control to 100%.
3. Observe that sound is audible.
  
Additional info:
The 'amixer_before.txt' file may not have the exact default setting for 'front'. However, I am certain that 'front' is the only control that I adjusted in alsamixer.
Comment 1 Chris Tyler 2009-05-08 09:45:03 EDT
Created attachment 343081 [details]
mixer values before fix
Comment 2 Chris Tyler 2009-05-08 09:45:45 EDT
Created attachment 343082 [details]
settings after adjusting 'front' to 100%
Comment 3 Chris Tyler 2009-05-08 09:46:50 EDT
Created attachment 343083 [details]
output of lshw

Since there are several different laptop configurations with similar designations, I've also attached the 'lshw' output.
Comment 4 Adam Williamson 2009-05-15 11:55:41 EDT
Jaroslav, was this one done in 1.0.20?

Chris, once you adjust front to 100%, do Pulse volume controls then give a reasonable range of adjustment - i.e., when you set the Pulse slider to 0, does it still go quiet?
Comment 5 Chris Tyler 2009-05-15 22:12:53 EDT
(In reply to comment #4)
> Chris, once you adjust front to 100%, do Pulse volume controls then give a
> reasonable range of adjustment - i.e., when you set the Pulse slider to 0, does
> it still go quiet?  

Yes, with front at 100% it operates as expected. I think the headphone setting should also be put all the way up, but haven't confirmed that.

(Unclear on whether to set the NEEDINFO flag to '+' or ' ', trying '+').
Comment 6 Adam Williamson 2009-05-15 23:07:38 EDT
Thanks.
Comment 7 Jaroslav Kysela 2009-05-21 05:07:25 EDT
The alsa-utils-1.0.20-3 package should fix this issue. Reopen this bug if the problem persist.

Note You need to log in before you can comment on or make changes to this bug.