Bug 499866 - KRunner crashes after searching in the System Activity process list
KRunner crashes after searching in the System Activity process list
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 12:08 EDT by Nelson Chan
Modified: 2009-05-29 20:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 20:36:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 191689 None None None Never

  None (edit)
Description Nelson Chan 2009-05-08 12:08:30 EDT
Description of problem:
i hit ctrl-esc to bring up the System monitor, and then i search for "mplayer"
to terminate a mplayer process that i want to, and i try to start a new search  and suddenly it crash.

Version-Release number of selected component (if applicable):
qt-4.5.0-14.fc11.x86_64
qt-4.5.0-14.fc11.i586
kdebase-4.2.2-2.fc11.x86_64


How reproducible:
It seems that to start a new search while terminating a process will trigger the crash.

Steps to Reproduce:
1. start up System Activity (by Ctrl-Esc)
2. search and terminate a process
3. quickly start a new search
4. crash
  
Actual results:
System Activity crash and closed automatically and kcrash catch the backtrace.

Expected results:
Should work fine and do the search

Additional info:
Already reported at https://bugs.kde.org/show_bug.cgi?id=191689

Here is the most recent backtrace i had:

--------------------
Application: Run Command Interface (krunner), signal SIGSEGV
0x0000003b772a5151 in nanosleep () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7ffe83de8860 (LWP 8990))]

Thread 1 (Thread 0x7ffe83de8860 (LWP 8990)):
[KCrash Handler]
#5  0x0000003b84d1d88f in ?? () from /usr/lib64/libQtGui.so.4
#6  0x0000003b84d1d94d in QSortFilterProxyModel::mapFromSource(QModelIndex
const&) const () from /usr/lib64/libQtGui.so.4
#7  0x0000003b84d18339 in QSortFilterProxyModel::parent(QModelIndex const&)
const () from /usr/lib64/libQtGui.so.4
#8  0x0000003b82b39e2c in
QAbstractItemModelPrivate::rowsAboutToBeRemoved(QModelIndex const&, int, int)
() from /usr/lib64/libQtCore.so.4
#9  0x0000003b84d1a849 in ?? () from /usr/lib64/libQtGui.so.4
#10 0x0000003b84d1a9b0 in ?? () from /usr/lib64/libQtGui.so.4
#11 0x0000003b84d1abc6 in ?? () from /usr/lib64/libQtGui.so.4
#12 0x0000003b84d207dc in QSortFilterProxyModel::qt_metacall(QMetaObject::Call,
int, void**) () from /usr/lib64/libQtGui.so.4
#13 0x0000003b86c1c2e0 in ProcessFilter::qt_metacall(QMetaObject::Call, int,
void**) () from /usr/lib64/libprocessui.so.4
#14 0x0000003b82b58612 in QMetaObject::activate(QObject*, int, int, void**) ()
from /usr/lib64/libQtCore.so.4
#15 0x0000003b82b8eaf4 in QAbstractItemModel::rowsAboutToBeRemoved(QModelIndex
const&, int, int) () from /usr/lib64/libQtCore.so.4
#16 0x0000003b82b3a3f3 in QAbstractItemModel::beginRemoveRows(QModelIndex
const&, int, int) () from /usr/lib64/libQtCore.so.4
#17 0x0000003b86c1df8e in ?? () from /usr/lib64/libprocessui.so.4
#18 0x0000003b86c1edbb in ?? () from /usr/lib64/libprocessui.so.4
#19 0x0000003b82b58612 in QMetaObject::activate(QObject*, int, int, void**) ()
from /usr/lib64/libQtCore.so.4
#20 0x0000003b81604d02 in
KSysGuard::Processes::beginRemoveProcess(KSysGuard::Process*) () from
/usr/lib64/libprocesscore.so.4
#21 0x0000003b81607785 in ?? () from /usr/lib64/libprocesscore.so.4
#22 0x0000003b8160774f in ?? () from /usr/lib64/libprocesscore.so.4
#23 0x0000003b8160774f in ?? () from /usr/lib64/libprocesscore.so.4
#24 0x0000003b81606c72 in KSysGuard::Processes::processesUpdated() () from
/usr/lib64/libprocesscore.so.4
#25 0x0000003b81606dc4 in KSysGuard::Processes::qt_metacall(QMetaObject::Call,
int, void**) () from /usr/lib64/libprocesscore.so.4
#26 0x0000003b82b58612 in QMetaObject::activate(QObject*, int, int, void**) ()
from /usr/lib64/libQtCore.so.4
#27 0x0000003b86c1cf61 in ProcessModel::update(int) () from
/usr/lib64/libprocessui.so.4
#28 0x0000003b86c124b4 in KSysGuardProcessList::updateList() () from
/usr/lib64/libprocessui.so.4
#29 0x0000003b86c19fdb in KSysGuardProcessList::qt_metacall(QMetaObject::Call,
int, void**) () from /usr/lib64/libprocessui.so.4
#30 0x0000003b82b58612 in QMetaObject::activate(QObject*, int, int, void**) ()
from /usr/lib64/libQtCore.so.4
#31 0x0000003b82b52353 in QObject::event(QEvent*) () from
/usr/lib64/libQtCore.so.4
#32 0x0000003b8478deac in QApplicationPrivate::notify_helper(QObject*, QEvent*)
() from /usr/lib64/libQtGui.so.4
#33 0x0000003b847954de in QApplication::notify(QObject*, QEvent*) () from
/usr/lib64/libQtGui.so.4
#34 0x0000003b85c05c66 in KApplication::notify(QObject*, QEvent*) () from
/usr/lib64/libkdeui.so.5
#35 0x0000003b82b42b7c in QCoreApplication::notifyInternal(QObject*, QEvent*)
() from /usr/lib64/libQtCore.so.4
#36 0x0000003b82b6e562 in ?? () from /usr/lib64/libQtCore.so.4
#37 0x0000003b82b6c05d in ?? () from /usr/lib64/libQtCore.so.4
#38 0x0000003b7963818e in g_main_context_dispatch () from
/lib64/libglib-2.0.so.0
#39 0x0000003b7963b8e8 in ?? () from /lib64/libglib-2.0.so.0
#40 0x0000003b7963ba5c in g_main_context_iteration () from
/lib64/libglib-2.0.so.0
#41 0x0000003b82b6bfa6 in
QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /usr/lib64/libQtCore.so.4
#42 0x0000003b848220de in ?? () from /usr/lib64/libQtGui.so.4
#43 0x0000003b82b41452 in
QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from
/usr/lib64/libQtCore.so.4
#44 0x0000003b82b41824 in
QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
/usr/lib64/libQtCore.so.4
#45 0x0000003b82b43919 in QCoreApplication::exec() () from
/usr/lib64/libQtCore.so.4
#46 0x0000003b886212bc in kdemain () from /usr/lib64/libkdeinit4_krunner.so
#47 0x0000003b7721e9dd in __libc_start_main () from /lib64/libc.so.6
#48 0x0000000000400779 in _start ()
----------------------
Comment 1 Rex Dieter 2009-05-08 12:14:53 EDT
Thanks, will take a look, but we'll likely continue to track this upstream.
Comment 2 Nelson Chan 2009-05-08 12:37:18 EDT
Just let me know if any info is needed from me.
i'm still trying to figure out a CONFIRMED way to reproduce.
Comment 3 Steven M. Parrish 2009-05-29 20:36:15 EDT
I tried and was unable to reproduce on my system.  I appreciate you taking the time to file this report upstream.  Will close this for now and we will monitor the upstream report for a resolution.

Note You need to log in before you can comment on or make changes to this bug.