Bug 499889 - Cobbler not fully configured by Satellite install script
Cobbler not fully configured by Satellite install script
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
: 589693 (view as bug list)
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-05-08 14:42 EDT by Steve Salevan
Modified: 2010-05-12 09:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:25:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-05-08 14:42:22 EDT
Description of problem:
If a user runs a the installation script that comes with RHN Satellite, they will discover that, after running 'cobbler check', a few things remain unconfigured:

[root@530sat ~]# cobbler check
/bin/sh: /usr/sbin/semanage: No such file or directory
The following potential problems were detected:
#0: you need to set some SELinux content rules to ensure cobbler works correctly in your SELinux environment, run the following: /usr/sbin/semanage fcontext -a -t public_content_t "/var/lib/tftpboot/.*" && /usr/sbin/semanage fcontext -a -t public_content_t "/var/www/cobbler/images/.*"
#1: change 'disable' to 'no' in /etc/xinetd.d/tftp
#2: reposync is not installed, need for cobbler reposync, install/upgrade yum-utils?
#3: yumdownloader is not installed, needed for cobbler repo add with --rpm-list parameter, install/upgrade yum-utils?
#4: The default password used by the sample templates for newly installed machines (default_password_crypted in /etc/cobbler/settings) is still set to 'cobbler' and should be changed
#5: fencing tools were not found, and are required to use the (optional) power management features. install cman to use them

Some of these options might be up to the user to configure, but as it stands, the user might be led to believe that no further configuration is required.

Version-Release number of selected component (if applicable):
530, 5/1 build

How reproducible:
Always

Steps to Reproduce:
1. Run Satellite install script
2. Read through the dialog presented to the user
3. Run a 'cobbler check'
  
Actual results:
User not told that further configuration is required (if it is), or cobbler check emits errors similar to those reported

Expected results:
User either told that further configuration is required or cobbler check does not emit errors

Additional info:
Comment 1 Clifford Perry 2009-05-12 11:54:11 EDT
So 

cobbler check is a documented command. 

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.3.0/html/Reference_Guide/ch-cobbler.html#s2-cobbler-reqs-check


All the output is controlled by Cobbler. I would suggest that Mike McCune/Justin/Partha works with Michael DeHann to create new bug(s) under cobbler upstream to address the issue. 

I suspect that improved wording would be nice. Most of these are relevant - depending on your planned usage of cobbler within Satellite. If your not doing PXE boot environment off Satellite then do not worry. Same for SELinux and the other items listed. 

So just clearer wording, but do not stop the display of these messages. Of course the Cobbler team (Mike, Justin, Partha with Michael) may on review determine that some of these should have indeed already been addressed during the installation part. 

Cliff
Comment 3 Brandon Perkins 2009-05-13 00:59:13 EDT
As stated in Comment #1, this bug is to act as a tracker or task list for Satellite Development to create new tickets against Cobber to get the correct behavior for Satellite usage.  It is intended for this to be an effort where "Mike
McCune/Justin/Partha works with Michael DeHann to create new bug(s) under cobbler upstream to address the issue."  This bug should not be assigned to Michael DeHann as there are no specific actions, and this is a Satellite bug, not a Cobbler bug.
Comment 4 Michael DeHaan 2009-05-13 08:17:18 EDT
Agreed, these are steps that either the user or the Satellite installer did not complete and is not a Cobbler bug.

A cobbler bug would be if one of these items were fixed and cobbler is still mentioning they should be addressed.

Assign these to someone working on the Sat integration if we believe this is something the Satellite installer should be taking care of.
Comment 7 Justin Sherrill 2009-06-11 10:58:33 EDT
cobbler ticket filed:

https://fedorahosted.org/cobbler/ticket/461
Comment 8 Steve Salevan 2009-06-24 15:07:55 EDT
VERIFIED on 6/19 build.
Comment 9 Steve Salevan 2009-07-29 17:42:06 EDT
RELEASE_PENDING from 7/24 build.
Comment 10 Brandon Perkins 2009-09-10 15:25:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html
Comment 11 Clifford Perry 2010-05-12 09:31:39 EDT
*** Bug 589693 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.