Bug 499914 - phasex not built with $RPM_OPT_FLAGS
phasex not built with $RPM_OPT_FLAGS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: phasex (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-05-08 17:19 EDT by Ville Skyttä
Modified: 2009-12-28 02:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-28 02:10:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build with $RPM_OPT_FLAGS (2.50 KB, patch)
2009-05-08 17:19 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2009-05-08 17:19:00 EDT
Created attachment 343178 [details]
Build with $RPM_OPT_FLAGS

Fix attached, see bug 496968 for more info.
Comment 1 Bug Zapper 2009-06-09 11:29:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Ville Skyttä 2009-06-09 14:55:30 EDT
Patch applied in CVS/devel due to no feedback in a month+, build attempted for Rawhide but it fails due to reasons unrelated to this patch (fails the same way without it):

In file included from wave.c:27:
phasex.h:30: error: conflicting types for 'float_t'In file included from engine.c:28:
phasex.h:30: error: conflicting types for 'float_t'
/usr/include/bits/mathdef.h:36: note: previous declaration of 'float_t' was here
/usr/include/bits/mathdef.h:36: note: previous declaration of 'float_t' was here
In file included from wave.h:27,
                 from filter.c:27:
phasex.h:30: error: conflicting types for 'float_t'
/usr/include/bits/mathdef.h:36: note: previous declaration of 'float_t' was here
Comment 3 Noura El hawary 2009-06-09 17:48:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Anthony Green 2009-12-28 02:10:48 EST
This was fixed in 0.12.0-0.1.beta4.

Note You need to log in before you can comment on or make changes to this bug.