Bug 499922 - banshee doesn't download podcasts nor allow saving to mp3 player
banshee doesn't download podcasts nor allow saving to mp3 player
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 19:38 EDT by Jason Haar
Modified: 2010-06-01 12:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 12:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Haar 2009-05-08 19:38:54 EDT
Description of problem:

If I download as podcast, banshee no longer marks it as downloaded (it does under FC10). Also, if I try drag-n-dropping it to my mp3 player, nothing happens.

Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1. subscribe to podcast. Choose mp3 to download. 
2. download occurs, but item not marked as downloaded
3. then if you drag-n-drop it onto mp3 player, no error occurs, but nothing happens
  
Actual results:


Expected results:

Under FC10 this all worked.


Additional info:
Comment 1 David Nielsen 2009-05-09 03:00:32 EDT
What mp3 player do you have?
Comment 2 Jason Haar 2009-05-09 05:34:07 EDT
It's actually a Blackberry - but it's just me dragging a MP3 onto the device within banshee.

BTW: I've got rhythmbox installed too and it works 100% fine: downloaded podcasts show up tagged as downloaded, and dragging them onto my BB works. Neither of those options work with banshee. 

I have also run banshee from a shell - and no error messages show up to indicate a problem

Jason
Comment 3 David Nielsen 2009-05-09 05:42:27 EDT
I was more concerned with if it was say an iPod or using some strange protocol which we might have broken. I assume the blackberry uses mtp.

was the run in the terminal done with --debug ?
Comment 4 Jason Haar 2009-05-09 07:30:14 EDT
No - but I just tried it again with --debug, it printed "** Running Mono with --debug   **" but otherwise made no difference - no other output. Problem with Downloads not being marked as downloaded continues. 

Isn't the mp3 player bit a red herring? I mean, if banshee hasn't figured out it has downloaded a file, then copying it to any MP3 player is going to fail (as it doesn't think it has a copy?)
Comment 5 David Nielsen 2009-05-09 07:45:23 EDT
The downloading bit is know. It is a problem with the server. We have a temporary workaround to discard downloads that terminate the connection or times out. It's not as such a problem with Banshee, but we could handle such situations nicer.

See:
http://bugzilla.gnome.org/show_bug.cgi?id=536047
Comment 6 David Nielsen 2009-05-09 07:55:29 EDT
hrmm there is one strange bit though, with the version in F10 at least (and F11 I believe) there should be a patch to stop swallowing the exceptions on download errors. I put it in there as my last action as a Fedora developer. Thus there should be some output we could use to see the exact nature of the download problem.
Comment 7 Bug Zapper 2009-06-09 11:30:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2010-04-27 10:14:07 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Benjamín Valero Espinosa 2010-06-01 12:03:44 EDT
Thank you for your bug report.
We are sorry, but the Fedora Project no longer maintains this version of Fedora. Please upgrade to the latest version and reopen this buga gainst that version if this bug exists there.
As a result we are setting this bug to CLOSED:WONTFIX



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.