Bug 499939 - yum segfault during plugin load - can't update
yum segfault during plugin load - can't update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libsmbios (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-05-09 05:02 EDT by David Timms
Modified: 2014-01-21 18:09 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.1.2-4.3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2009-05-09 05:02:36 EDT
Description of problem:
yum segfaults before update process really gets started.

Version-Release number of selected component (if applicable):
python-2.6-7.fc11.i586
rpm-4.7.0-1.fc11.i586
rpm-build-4.7.0-1.fc11.i586
rpmdevtools-7.1-1.fc11.noarch
rpmfusion-free-release-10.90-2.noarch
rpmfusion-nonfree-release-10.90-2.noarch
rpm-libs-4.7.0-1.fc11.i586
rpmlint-0.87-1.fc11.noarch
rpm-python-4.7.0-1.fc11.i586
yum-3.2.22-4.fc11.noarch
yum-metadata-parser-1.1.2-12.fc11.i586
yum-metadata-parser-debuginfo-1.1.2-12.fc11.i586
yum-plugin-allowdowngrade-1.1.21-2.fc11.noarch
yum-plugin-downloadonly-1.1.21-2.fc11.noarch
yum-presto-0.4.5-4.fc11.noarch
yum-utils-1.1.21-2.fc11.noarch

How reproducible:
Only 1 machine, but continues with each attempted yum run.

Steps to Reproduce:
1. fedora 10, updated
2. f11 preview upgrade via dvd
3. yum update yum rpm hal udev kernel
4. reboot
5. yum update (had trouble)
6. yum smaller groups like a* b* etc
7. yum stopped working
8. reboot
  
Actual results:
$ yum
Loaded plugins: allowdowngrade, dellsysidplugin2, downloadonly, presto, refresh-
              : packagekit
Segmentation fault
===
$ yum -d 15
Loading "allowdowngrade" plugin
Not loading "blacklist" plugin, as it is disabled
Loading "dellsysidplugin2" plugin
Loading "downloadonly" plugin
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Running "config" handler for "allowdowngrade" plugin
Running "config" handler for "downloadonly" plugin
Running "config" handler for "presto" plugin
Running "postconfig" handler for "dellsysidplugin2" plugin
Segmentation fault
===
$ yum -d 15 list installed gkrellm
Loading "allowdowngrade" plugin
Not loading "blacklist" plugin, as it is disabled
Loading "dellsysidplugin2" plugin
Loading "downloadonly" plugin
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Running "config" handler for "allowdowngrade" plugin
Running "config" handler for "downloadonly" plugin
Running "config" handler for "presto" plugin
Running "postconfig" handler for "dellsysidplugin2" plugin
Segmentation fault
===
$ yum --noplugins -d 15 list gkrellm
Config time: 0.682
Yum Version: 3.2.22
COMMAND: yum --noplugins -d 15 list gkrellm 
Installroot: /
Ext Commands:

   gkrellm
Setting up Package Sacks
pkgsack time: 0.562
Reading Local RPMDB
rpmdb time: 0.000
Matching packages for package list to user args
Installed Packages
gkrellm.i586                       2.3.2-4.fc11                        installed
===
$ yum --disableplugin=dellsysidplugin2 -d 15 list gkrellm
Loading "allowdowngrade" plugin
Not loading "blacklist" plugin, as it is disabled
Loading "downloadonly" plugin
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Running "config" handler for "allowdowngrade" plugin
Running "config" handler for "downloadonly" plugin
Running "config" handler for "presto" plugin
Config time: 1.822
Yum Version: 3.2.22
COMMAND: yum --disableplugin=dellsysidplugin2 -d 15 list gkrellm 
Installroot: /
Ext Commands:

   gkrellm
Setting up Package Sacks
Running "postreposetup" handler for "downloadonly" plugin
pkgsack time: 0.496
Reading Local RPMDB
rpmdb time: 0.000
ctrl-c took more than 5 minutes and did not complete.
===

Expected results:
working yum.

Additional info: seems to be an issue around dellsysidplugin2 (which I didn't specifically installed, unsure where it came from).
Also, after attempted --noplugin yum run (that couldn't complete), machine is using all memory (1.5GB ram + 1GB swap): sedispatch 84.5% mem in top.
Comment 1 David Timms 2009-05-10 08:54:40 EDT
see bug 483264. Unfortunately that bug seems to have been closed against yum, when perhaps it should have been readdigned to the package that provides the plugin that causes the segfault, doing that here.
---
2007-Dec 08 18:13:46 Updated:   libsmbios-libs - 0.13.13-1.fc8.i386
2007-Dec 08 18:23:34 Updated:   libsmbios-bin - 0.13.13-1.fc8.i386
2008-Nov 29 14:11:41 Installed: libsmbios-debuginfo-2.0.1-2.fc9.1.i386
2008-Dec 31 06:33:29 Updated:   libsmbios-debuginfo-2.0.1-2.fc10.1.i386

2009-May 09 13:18:12 Updated:   libsmbios-debuginfo-2.2.15-3.fc11.i586
2009-May 09 13:19:40 Updated:   libsmbios-2.2.15-3.fc11.i586
2009-May 09 13:20:20 Installed: smbios-utils-bin-2.2.15-3.fc11.i586
2009-May 09 13:23:11 Installed: python-smbios-2.2.15-3.fc11.i586
2009-May 09 13:23:12 Installed: smbios-utils-python-2.2.15-3.fc11.i586
2009-May 09 13:23:32 Updated:   smbios-utils-2.2.15-3.fc11.i586

It seems the F10 upgrade to F11preview caused the installation of this package. Possibly both the application needs to be fixed, and the package fixed to not install on non-dell machines if it isn't intended for them. I never saw indication of this plugin before the upgrade to F11preview.
Comment 2 Matt Domsch 2009-05-16 09:22:52 EDT
Please try with newer firmware-addon-dell and firmware-tools landing in updates-testing in the next 24 hours or so.
Comment 3 Matěj Cepl 2009-05-16 16:40:48 EDT
Seems like there is not much to be added. Reporter, can you reproduce this with http://koji.fedoraproject.org/koji/buildinfo?buildID=102334 and http://koji.fedoraproject.org/koji/buildinfo?buildID=102297 ?

Thank you
Comment 4 Matt Domsch 2009-05-16 18:00:06 EDT
the plugin comes from smbios-utils-python, where a bug was fixed in 2.2.16 that might account for this.

2.2.16 isn't released in Fedora yet, but it is in the Dell Community repository (http://linux.dell.com/repo/community).

I'll see about getting it built for F-11 updates-testing.
Comment 5 Fedora Update System 2009-05-16 22:39:23 EDT
libsmbios-2.2.16-2.1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libsmbios-2.2.16-2.1.fc11
Comment 6 Matt Domsch 2009-05-16 22:40:49 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=102202
has the fixed libsmbios, if you care to try before it hits updates-testing.
Comment 7 David Timms 2009-05-17 20:22:09 EDT
Matt, I was concerned that having unusable yum just after a user upgrades from f10 -> f11 would really spoil the fun. Can/will this make it into the release isos ?
Did the package change so that the sysid yum plugin is _not_ auto installed during upgrade (or is the intent to have it on all users machines) ?
Comment 8 David Timms 2009-05-17 20:24:58 EDT
(In reply to comment #2)
> Please try with newer firmware-addon-dell and firmware-tools landing in
> updates-testing in the next 24 hours or so.  
How would that help a person who upgrades to F11 (ie rawhide) ?
Comment 9 Matt Domsch 2009-05-17 23:10:05 EDT
this is a bit confusing I admit; I'm just coming to grips with it myself.

In F9 and F10, hal requires libsmbios and smbios-utils.  smbios-utils requires smbios-utils-python, and s-u-p provides dellsysidplugin2.  So users upgrading from F9 or F10 to F11 will have had smbios-utils-python pulled in.  (Fresh installs of F11 should not, as hal no longer depends on libsmbios or smbios-utils).  The libsmbios/smbios-utils* package in dist-f11 is buggy and causing the setfault.  So upgraders could easily run into the problem, and be unable to run yum after doing an upgrade.  That would be awful.

Thanks for noticing, and raising the alarm.  I'll ask libsmbios-2.2.16* get tagged into dist-f11.
Comment 10 Matt Domsch 2009-05-18 13:19:45 EDT
Jesse tagged libsmbios-2.2.16 into f11-final.
Comment 11 Jesse Keating 2009-05-18 16:43:26 EDT
Closing.
Comment 12 Fedora Update System 2009-06-15 21:29:38 EDT
firmware-tools-2.1.5-1.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-06-15 21:46:42 EDT
firmware-addon-dell-2.1.2-4.3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-06-15 22:00:57 EDT
firmware-tools-2.1.5-1.1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-06-15 22:01:49 EDT
firmware-tools-2.1.5-1.1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-06-15 22:09:23 EDT
firmware-addon-dell-2.1.2-4.3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2009-06-15 22:15:19 EDT
firmware-addon-dell-2.1.2-4.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.