Bug 499955 - Improve RHEL5 boot time by fixing nash's stabilized command
Improve RHEL5 boot time by fixing nash's stabilized command
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.4
All Linux
low Severity high
: rc
: ---
Assigned To: Peter Jones
Release Test Team
https://bugzilla.redhat.com/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 10:04 EDT by Dag Wieers
Modified: 2010-07-01 23:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 23:05:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2009-05-09 10:04:58 EDT
Description of problem:
Booting RHEL5 takes more time then necessary because nash's stabilized function has a bug. The fix is available from #193206 in rawhide, but it would be a small effort to port this back to RHEL 5.4.

The difference between booting without the current stabilized function makes a huge difference (more than 15 seconds) so if this is fixed it makes a big difference resuming from hibernate.

And it may look nice on the feature list too :-)

Version-Release number of selected component (if applicable):
RHEL 5.3 and earlier
mkinitrd-5.1.19.6-44

How reproducible:
Everytime

Steps to Reproduce:
1. echo stabilized / | time strace nash
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dag Wieers 2009-05-09 10:06:42 EDT
Bug 193206 ?
Comment 2 Dag Wieers 2009-07-22 12:43:10 EDT
Can someone from Red Hat please investigate ?

I am sure we now missed the opportunity for RHEL 5.4... :-/
Comment 3 Denise Dumas 2009-07-22 12:54:04 EDT
This was never even proposed for 5.4, would be 5.5 at absolute best given the gazillion conflicting and higher priorities, and that's if a miracle happens. 
If this is a big issue for you, please escalate it through your support channel.
Comment 4 cheguaka 2010-02-15 03:29:30 EST
Will this bug be fixed for 5.5?
Comment 5 RHEL Product and Program Management 2010-07-01 23:05:01 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.