This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 499963 - reinstall over existing system fails on Apple hardware
reinstall over existing system fails on Apple hardware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-05-09 12:01 EDT by Tom Lane
Modified: 2013-07-02 23:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 16:22:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
traceback for failure to reinstall (94.03 KB, text/plain)
2009-05-09 12:01 EDT, Tom Lane
no flags Details

  None (edit)
Description Tom Lane 2009-05-09 12:01:39 EDT
Created attachment 343218 [details]
traceback for failure to reinstall

Description of problem:
Installing rawhide into free space on a Powerbook G3 laptop works, but reinstalling over that
installation fails.

Version-Release number of selected component (if applicable):
anaconda 11.5.0.51

How reproducible:
100% I think (didn't try more than once)

Steps to Reproduce:
1. Select "replace existing system" option during text-mode install
2.
3.
  
Actual results:
fails with traceback (attached)

Expected results:
should replace old installation

Additional info:
continuation of bug #492154
Comment 1 Chris Lumens 2009-05-11 10:49:40 EDT
Does using updates=http://clumens.fedorapeople.org/499963.img fix your problem?
Comment 2 Tom Lane 2009-05-11 11:12:41 EDT
Pardon my ignorance, but I don't understand exactly what I'm supposed to do with this file?
Comment 3 Chris Lumens 2009-05-11 11:19:59 EDT
If you have a network connection, at the CD bootloader screen, you just need to append updates= to the boot arguments.  Otherwise, you need to copy the updates image onto a USB key and add "updates" to the boot arguments.  Doing it via the network really is easiest.
Comment 4 Tom Lane 2009-05-11 11:48:28 EDT
NAK: exact same traceback with this update applied.
Comment 5 Jóhann B. Guðmundsson 2009-05-11 12:53:21 EDT
what happens if you first delete the previously created partition then recreate them from free space? 

Looks like /boot is the culprit either the partition is missing or got some how corrupted during the initial creation?
Comment 6 Tom Lane 2009-05-11 13:08:58 EDT
Well, this is a text-mode install, so it is not offering me the option to fool with the partition table by hand.

Since the previous installation had been working just fine, I kinda doubt the theory that there was something wrong with its /boot partition.
Comment 7 Chris Lumens 2009-05-11 13:21:50 EDT
Are you sure the updates image is being used?  I don't see how it could be the same traceback given that the code is totally changed around now and you can't get to the startswith() call without at least having an empty string instead of None.

You can verify the updates image is being used if there's /tmp/updates/*.pyc, and there should be some mention of it in your /tmp/anaconda.log file.
Comment 8 Tom Lane 2009-05-11 14:24:24 EDT
Hmmm, I was wondering about the line numbers being the same.

What I see is that it asks me which disk to get updates from, I select /dev/sda, then it says "Reading anaconda updates" for a few seconds and then proceeds with no hint of an error, so at the very least you've got a user interface deficiency here...

After it's crashed, I look into /tmp/updates/ and see 499963.img (as well as a couple of other files that were on my USB stick); but nothing *.pyc.  /tmp/anaconda.log has a line "UPDATES device is /dev/sda" but nothing further that seems related.

I think you are probably right that the update wasn't used, but how do I find out why not?

(PS: I'm using the USB stick method because, as usual, NetworkManager is utterly useless in a DHCP-free environment.)
Comment 9 Will Woods 2009-05-12 13:50:17 EDT
Works for me using 499963.img and current rawhide anaconda (11.0.5.51). I'm installing a new copy of rawhide over itself right now.
Comment 10 Tom Lane 2009-05-12 15:49:15 EDT
After turning on a DHCP server I can confirm that 499963.img seems to fix the problem.  I'm still wondering why the non-network approach to installing the update doesn't work.

Also, I notice that the update enables a "use VNC" prompt, which is nice, but if you back up from that the plain text mode is all wonky --- the text box boundary lines are replaced by LATIN1 letters ...
Comment 11 Tom Lane 2009-05-14 16:07:26 EDT
Original problem confirmed fixed in today's rawhide (anaconda .52).  Is it useful filing bugs about the other two issues mentioned in comment #10?  I do not see the VNC option offered by .52, so I'm unsure if that was just experimental code or something that should work.
Comment 12 Jesse Keating 2009-05-14 16:22:12 EDT
Doesn't hurt to file the bugs.  I'll close this one since you've confirmed it.

Note You need to log in before you can comment on or make changes to this bug.