Bug 499964 - ppc install does not provide bootloader menu entry for existing OS X system
ppc install does not provide bootloader menu entry for existing OS X system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-05-09 12:09 EDT by Tom Lane
Modified: 2013-07-02 23:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 15:56:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2009-05-09 12:09:45 EDT
Description of problem:
When installing onto a disk that contains an existing bootable OS X system, I think that the bootloader
should be configured to offer that system as one of the boot menu options.  It currently fails to do so.

Version-Release number of selected component (if applicable):
anaconda 11.5.0.51

How reproducible:
100% I think (didn't try more than once)

Steps to Reproduce:
1.  With Apple's Disk Utility, partition disk into one partition and an equal amount of free space.
2.  Install OS X into the one partition.
3.  Install Fedora using the "install into free space" option.
  
Actual results:
boot loader offers only Fedora, CD, and network boot options.
The OSX system is still there, but can only get into it via Open Firmware option-key method.

Expected results:
boot loader menu should offer the OSX system as one option

Additional info:
Tested on Powerbook G3 laptop, using the text-mode install due to unrelated X11 issue.
Comment 1 Will Woods 2009-05-11 17:50:30 EDT
Confirmed here on a G5 Power Mac. Bootloader screen never appeared during the install.
Comment 2 Chris Lumens 2009-05-13 16:09:32 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 3 Tom Lane 2009-05-14 15:56:16 EDT
Confirmed fixed in .52.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.