Bug 499965 - [enh] port to PolicyKit 1.0
[enh] port to PolicyKit 1.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 12:40 EDT by Matthias Clasen
Modified: 2011-02-24 00:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 00:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (8.85 KB, patch)
2009-06-02 23:07 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2009-05-09 12:40:13 EDT
We are going to land polkit 1.0 in F12 soon. This is going to require changes to polkit using applications. Thankfully, mostly simplifications.

See http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 Niels Haase 2009-05-11 05:11:05 EDT
This bug has been triaged.

Changing title to reflect the enhancement request.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Dan Williams 2009-05-14 14:35:29 EDT
PK 1.0 port should just be done on NM & applet master branch (ie, NM 0.8).  I don't think it makes a lot of sense to port NM 0.7.x, especially because we'd have to either have a lot of #ifdefs, or a bunch of compat code.
Comment 3 Matthias Clasen 2009-05-26 13:58:34 EDT
Is NM 0.8 going to happen for F12 ?
Comment 4 Dan Williams 2009-05-26 14:29:15 EDT
That's my plan...
Comment 5 Matthias Clasen 2009-06-02 23:06:57 EDT
Here is a very simple-minded patch for NM
Comment 6 Matthias Clasen 2009-06-02 23:07:46 EDT
Created attachment 346344 [details]
patch
Comment 7 Dan Williams 2009-08-26 15:04:03 EDT
Merged to master of both NM and the applet as of:

79489be3b5e6d2c60b401b5265fa37093553e871 (nm)
eb452a735625fd9e5c0b004be799a5949952a984 (applet)
Comment 8 Dan Williams 2011-02-24 00:15:55 EST
Long since fixed.

Note You need to log in before you can comment on or make changes to this bug.