Bug 499971 - port to PolicyKit 1.0
port to PolicyKit 1.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups-pk-helper (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
: 500006 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 13:21 EDT by Matthias Clasen
Modified: 2010-01-14 03:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-14 03:35:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
polkit-1 patch (9.50 KB, patch)
2009-05-29 10:56 EDT, Marek Kašík
no flags Details | Diff
new specfile (2.95 KB, text/plain)
2009-05-29 10:59 EDT, Marek Kašík
no flags Details

  None (edit)
Description Matthias Clasen 2009-05-09 13:21:03 EDT
We are going to land polkit 1.0 in F12 soon. This is going to require changes
to polkit using applications. Thankfully, mostly simplifications.

See http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 Matthias Clasen 2009-05-10 00:26:12 EDT
*** Bug 500006 has been marked as a duplicate of this bug. ***
Comment 2 Marek Kašík 2009-05-29 10:56:39 EDT
Created attachment 345914 [details]
polkit-1 patch

Hi,
this patch implements support for PolicyKit 1. There are 2 little problems still. I don't see any status icon of PolicyKit and there is needed a change in system-config-printer, because it doesn't pass tuple with signature "as".

Marek
Comment 3 Marek Kašík 2009-05-29 10:59:03 EDT
Created attachment 345915 [details]
new specfile
Comment 4 Matthias Clasen 2009-05-29 13:55:55 EDT
The status icon has not been implemented yet.
Comment 5 Bug Zapper 2009-06-09 11:33:16 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Matthias Clasen 2009-06-11 12:26:00 EDT
PolicyKit 0.92 is in rawhide now, in the polkit packages, so this can land now.
Comment 7 Marek Kašík 2009-06-18 12:03:35 EDT
Committed and built.

Marek
Comment 8 Bug Zapper 2009-11-16 04:58:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.