Bug 499990 - nomodeset no longer works for ATI 9200
nomodeset no longer works for ATI 9200
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 17:07 EDT by Bruno Wolff III
Modified: 2009-05-18 09:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 09:32:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-05-09 17:07:52 EDT
Description of problem:
Recently my ATI stopped being used properly after a reboot. I tried downgrading a few things individually and didn't get it working normally again. But I am not sure what packages had changed between reboots. It was something within the last week though. Using modeset gets me by, but as mentioned in another bug console stuff and vts don't work in that case.
When the system get to the point where X is started the monitor loses signal. Trying to switch to a VT doesn't get signal either.
Connecting from another local system and looking around shows that the boot process seems to have completed normally. gdm appears to be running.
the -11, -12, and -13 versions of the ati driver all have the same symptom, though I am fairly sure that I had done a reboot after initially trying the -11 version. I have tried the -134 and -135 kernels and the -13 and -9 X servers.

Version-Release number of selected component (if applicable):


How reproducible:
Seems to happen 100%

Steps to Reproduce:
1. Boot with the nomodeset kernel parameter.
2.
3.
  
Actual results:
Black screen, no signal from the VGA port

Expected results:


Additional info:
Comment 1 Matěj Cepl 2009-05-12 17:53:32 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Bruno Wolff III 2009-05-18 09:32:10 EDT
nomodeset is working again. Possibly the -14 ati driver or a later kernel fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.