Bug 499998 - Root password not recognized
Root password not recognized
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 19:08 EDT by Mike Westkamper
Modified: 2015-01-14 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-17 16:26:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot log (2.48 KB, application/octet-stream)
2009-05-09 19:08 EDT, Mike Westkamper
no flags Details

  None (edit)
Description Mike Westkamper 2009-05-09 19:08:40 EDT
Created attachment 343242 [details]
boot log

Description of problem:

Cannot logon as root

Version-Release number of selected component (if applicable):

(See boot log attached)

How reproducible:

Every time try to logon as root

Steps to Reproduce:
1. Install Fedora 11
2. Select PW during install
3. During run try to logon as root from boot screen
4. To get to root functions:  Login as a standard user then SU and enter root pw
  
Actual results:


Expected results:


Additional info:

(See boot log)
Comment 1 Bob Relyea 2009-05-11 17:03:44 EDT
If pam_pkcs11 is involved, then this sounds like a myriad of configuration problems in pam.

1. Why is pam_pkcs11 involved. It should only be turned on unless you turn on smart card login (which doesn't appear in your reproduction instructions). Also, if you turn on smart card login, it should only prevent you from using regular login if there is a token present.

2. Why is it involved in SU. We specifically do not enable pam_pkcs11 for certain operations, like sudo and su.

Are you using smart card login, or is should this be a pam bug

bob
Comment 2 Mike Westkamper 2009-05-11 18:45:50 EDT
I selected pam_pkcell because I don't know better. I have no idea which module handles the login from the screen.

Mike
Comment 3 Bug Zapper 2009-06-09 11:34:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tomas Mraz 2010-03-17 16:26:32 EDT
I suppose you tried to log in as root from the gdm login screen. That is disable on purpose as you should not log in as root directly into graphical login session. Use the su command in terminal or login as root on the text console.

Note You need to log in before you can comment on or make changes to this bug.