Bug 50004 - Dell C800 laptop, XFree86-4.x sometimes freezes on reboot/logout/etc
Summary: Dell C800 laptop, XFree86-4.x sometimes freezes on reboot/logout/etc
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-25 21:48 UTC by Alexei Podtelezhnikov
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 23:55:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X Config file (16.27 KB, text/plain)
2001-08-16 14:26 UTC, Joseph Harnish
no flags Details
X Log file (26.27 KB, text/plain)
2001-08-16 14:27 UTC, Joseph Harnish
no flags Details

Description Alexei Podtelezhnikov 2001-07-25 21:48:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010712

Description of problem:
It works fine in general. However, XFree86-4.x freezes the machine entirely
(requiring hard reboot) on "logout"/"reboot"/"ctrl-alt-Fx" every once in a
while (one out of 7 times or so). Logs do not show anything of interest.
Altering XF86Config-4 does not change the behavior. GDM, or KDM, or text
login with startx later - makes no difference - it freezes. It looks like
the screen begins to white out, then stops, them pales to light grey. Then
you can do nothing but shutdown manually, or wait a minute or so, and
machine will shut down itself.

How reproducible:
Sometimes

Steps to Reproduce:
1. repeat ctrl-alt-backspace 7 times atp runlevel 5.
2. 
3.
	

Additional info: Dell Latitude C800 uses Rage 128 Mobility M4. XFree 4.1.0
from rawhide reveals the same problem. different kernels don't matter.
Nothing seems to matter.

Comment 1 Joseph Harnish 2001-08-10 13:53:06 UTC
I have the same problem on my C800 laptop.  I also encountered this with 7.1
when I installed Ximian on my laptop.  I believe the problem lies in the new
gnome packages.

Comment 2 Alexei Podtelezhnikov 2001-08-11 01:15:39 UTC
I see the problem even without both KDE and gnome under plain xdm.

I see the problem with Roswell as well.

Comment 3 Mike A. Harris 2001-08-16 02:19:42 UTC
Attach logs + configs please

Comment 4 Joseph Harnish 2001-08-16 14:26:08 UTC
Created attachment 28113 [details]
X Config file

Comment 5 Joseph Harnish 2001-08-16 14:27:40 UTC
Created attachment 28114 [details]
X Log file

Comment 6 Joseph Harnish 2001-11-12 16:40:02 UTC
I upgraded to 7.2 and it does not do this anymore.  

Thanks

Joe

Comment 7 Mike A. Harris 2001-11-13 00:08:36 UTC
Confirmed in email by others as well.  Setting status to MODIFIED
for confirmation by original submitter.  Will close as:
CLOSED->CURRENTRELEASE fixed in 7.2 when confirmed.

Comment 8 Alexei Podtelezhnikov 2001-11-19 02:53:17 UTC
Under Roswell and 7.1 the problem was fixed by setting up the "natural"
resolution 1400x1050 for this laptop flat panel. The problem went away with this
resolution. It's too bad anaconda and Xconfigurator had no idea of this
resolution. I didn't play with 7.2 yet.


Note You need to log in before you can comment on or make changes to this bug.