Bug 500057 - vesa driver stopped working inside KVM-84
vesa driver stopped working inside KVM-84
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 09:30 EDT by Sascha Silbe
Modified: 2009-05-30 10:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 14:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (909 bytes, text/plain)
2009-05-13 13:35 EDT, Sascha Silbe
no flags Details
Xorg.0.log for attached xorg.conf (Attachment #343822) (4.58 KB, text/plain)
2009-05-13 13:36 EDT, Sascha Silbe
no flags Details
Xorg.0.log when run without xorg.conf (6.15 KB, text/plain)
2009-05-13 13:37 EDT, Sascha Silbe
no flags Details
xorg.conf with BusID specified (930 bytes, text/plain)
2009-05-13 13:41 EDT, Sascha Silbe
no flags Details
Xorg.0.log for xorg.conf with BusID (Attachment #343825) (4.58 KB, text/plain)
2009-05-13 13:44 EDT, Sascha Silbe
no flags Details
Xorg.0.log with 1.6.1.901-1 / 2.2.0-3 (4.62 KB, text/plain)
2009-05-25 02:49 EDT, Sascha Silbe
no flags Details
Xorg.0.log for KVM-85 (4.62 KB, text/plain)
2009-05-30 10:20 EDT, Sascha Silbe
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 21661 None None None Never
Launchpad 356133 None None None Never

  None (edit)
Description Sascha Silbe 2009-05-10 09:30:07 EDT
Description of problem:
The Xorg vesa driver stopped recognizing the emulated graphics card (VESA mode) inside KVM-84.
Probably related to Ubuntu bug #356133.

Version-Release number of selected component (if applicable):
2.2.0-3.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. startx
  
Actual results:
From Xorg.0.log:
(II) VESA: driver for VESA chipsets: vesa
(WW) Falling back to old probe method for vesa
(EE) No devices detected.


Expected results:
Access emulated graphics card using vesa driver.

Additional info:
Host system: Debian lenny, x86_64, Linux 2.6.26 (standard Debian kernel), kvm-84
Comment 1 Sascha Silbe 2009-05-10 14:29:45 EDT
Filed upstream as #21661.
Comment 2 Matěj Cepl 2009-05-12 17:54:50 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Sascha Silbe 2009-05-13 13:35:01 EDT
Created attachment 343822 [details]
xorg.conf

This configuration worked fine before.
Comment 4 Sascha Silbe 2009-05-13 13:36:16 EDT
Created attachment 343823 [details]
Xorg.0.log for attached xorg.conf (Attachment #343822 [details])
Comment 5 Sascha Silbe 2009-05-13 13:37:56 EDT
Created attachment 343824 [details]
Xorg.0.log when run without xorg.conf
Comment 6 Sascha Silbe 2009-05-13 13:41:31 EDT
Created attachment 343825 [details]
xorg.conf with BusID specified
Comment 7 Sascha Silbe 2009-05-13 13:44:02 EDT
Created attachment 343827 [details]
Xorg.0.log for xorg.conf with BusID (Attachment #343825 [details])

It was reported that specifying the BusID worked in one particular case (with kvm-85 userspace, though), so I tested that as well. Made no difference.
Comment 8 Adam Jackson 2009-05-18 14:40:32 EDT
The pv console device doesn't claim its pci class correctly, and the X server treats it as a candidate primary video device.  This is way lame.

Fixed in 1.6.1.901-1.fc11
Comment 9 Sascha Silbe 2009-05-25 02:49:53 EDT
Created attachment 345277 [details]
Xorg.0.log with 1.6.1.901-1 / 2.2.0-3

Still fails for me with the same error message. Versions:
xorg-x11-drv-vesa 2.2.0-3.fc11.x86_64
xorg-x11-server-Xorg 1.6.1.901-1.fc11.x86_64
Comment 10 Sascha Silbe 2009-05-30 10:20:43 EDT
Created attachment 345973 [details]
Xorg.0.log for KVM-85

While I can now confirm it works using KVM-85 (not KVM-84) on Ubuntu Jaunty, it doesn't for Fedora.

Note You need to log in before you can comment on or make changes to this bug.