Bug 500069 - yum update now breaks after upgrade to F9
yum update now breaks after upgrade to F9
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 12:28 EDT by Gerry Reno
Modified: 2014-01-21 18:09 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 03:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Reno 2009-05-10 12:28:13 EDT
Description of problem:
upgraded machines to F9.
ran 'yum update' as root immediately after first reboot.  This goes well until the very end of cleanup when you see this:
  Cleanup   : mcstrans                     ##################### [446/448] 
  Cleanup   : nmap-frontend                ##################### [447/448] 
ERROR:dbus.connection:Unable to set arguments () according to signature u's': <type 'exceptions.TypeError'>: More items found in D-Bus signature than in Python arguments
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 432, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 790, in runTransaction
    self.plugins.run('posttrans')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 175, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/refresh-packagekit.py", line 37, in posttrans_hook
    packagekit_iface.StateHasChanged('posttrans')
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 597, in call_blocking
    message.append(signature=signature, *args)
TypeError: More items found in D-Bus signature than in Python arguments

This error occurs on every machine.

ran a second 'yum update' as now the updates-newkey repo was installed and this yum update fails with the following errors:
# yum update
Loaded plugins: fastestmirror, installonlyn, refresh-packagekit, versionlock
Loading mirror speeds from cached hostfile
 * updates-newkey: ftp.linux.ncsu.edu
 * fedora: ftp.linux.ncsu.edu
 * updates: ftp.linux.ncsu.edu
 * freshrpms: ayo.ie.freshrpms.net
fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 4.5 MB     00:02     
http://ftp.linux.ncsu.edu/pub/fedora/linux/updates/9/i386.newkey/repodata/fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2fa055b926-primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 4.5 MB     00:02     
http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/updates/9/i386.newkey/repodata/fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2fa055b926-primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.

This error also occurs on every machine.


What's interesting is that the first 'yum update' now gives you a whole list of packages whereas previously you would only get about 9 packages with PackageKit and fedora-release in the mix.  So something is now changed with how the F9 upgrade works.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. see description
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2009-05-11 03:00:24 EDT
Yes, this happens if you run a different version of yum with the PackageKit-yum-plugin. You can either ignore this message until you upgrade yum, PK and the reboot, or you can remove the yum PK plugin by doing yum remove "PackageKit-yum-plugin"
Comment 2 Gerry Reno 2009-05-11 11:12:08 EDT
Here's what I see on these machines after the second 'yum update' following the anaconda upgrade.  What exactly is wrong with these packages?  This all used to "just work".  But now it doesn't.


# yum list installed yum\* rpm\* PackageKit\*
Loaded plugins: fastestmirror, installonlyn, list-data, refresh-packagekit,
              : versionlock
Installed Packages
PackageKit.i386                          0.2.5-1.fc9            installed       
PackageKit-libs.i386                     0.2.5-1.fc9            installed       
rpm.i386                                 4.4.2.3-2.fc9          installed       
rpm-build.i386                           4.4.2.3-2.fc9          installed       
rpm-devel.i386                           4.4.2.3-2.fc9          installed       
rpm-libs.i386                            4.4.2.3-2.fc9          installed       
rpm-python.i386                          4.4.2.3-2.fc9          installed       
yum.noarch                               3.2.14-10.fc9          installed       
yum-fastestmirror.noarch                 1.1.13-2.fc9           installed       
yum-list-data.noarch                     1.1.13-2.fc9           installed       
yum-metadata-parser.i386                 1.1.2-8.fc9            installed       
yum-packagekit.i386                      0.2.5-1.fc9            installed       
yum-updatesd.noarch                      1:0.9-1.fc9            installed       
yum-versionlock.noarch                   1.1.13-2.fc9           installed       
# 
# yum list available yum\* rpm\* PackageKit\*
Loaded plugins: fastestmirror, installonlyn, list-data, refresh-packagekit,
              : versionlock
Loading mirror speeds from cached hostfile
 * updates-newkey: mirror.hiwaay.net
Excluding mirror: mirror.newnanutilities.org
 * fedora: mirror.hiwaay.net
 * freshrpms: ayo.ie.freshrpms.net
 * updates: mirror.hiwaay.net
updates-newkey                                           | 3.6 kB     00:00    
fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 4.5 MB     00:02     
http://mirror.hiwaay.net/pub/fedora/linux/updates/9/i386.newkey/repodata/fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2fa055b926-primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 4.5 MB     00:02     
http://archive.linux.duke.edu/pub/fedora/linux/updates/9/i386.newkey/repodata/fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2fa055b926-primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 1.2 MB     00:00     ^C

 Current download cancelled, interrupt (ctrl-c) again within two seconds to exit.

fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 128 kB     00:00    


Exiting on user cancel
Comment 3 Gerry Reno 2009-05-11 11:22:25 EDT
BTW, you can't "just ignore this message" because yum or repos is now broken and you cannot install anything after this error occurs.
Comment 4 Gerry Reno 2009-05-11 12:02:18 EDT
As I stated above, you cannot install (and apparently remove) anything after this error occurs.  Something has changed in the way the F9 upgrade process works.

# yum remove yum-packagekit
Loaded plugins: fastestmirror, installonlyn, list-data, refresh-packagekit,
              : versionlock
Setting up Remove Process
Loading mirror speeds from cached hostfile
 * updates-newkey: mirror.hiwaay.net
Excluding mirror: mirror.newnanutilities.org
 * fedora: mirror.hiwaay.net
 * freshrpms: ayo.ie.freshrpms.net
 * updates: mirror.hiwaay.net
fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 4.5 MB     00:01     
http://mirror.hiwaay.net/pub/fedora/linux/updates/9/i386.newkey/repodata/fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2fa055b926-primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 2.5 MB     00:01     ^C

 Current download cancelled, interrupt (ctrl-c) again within two seconds to exit.

fcabfc18906d2fc553c7fe1228ef87166c449a30e9e1a32678d1ba2f | 584 kB     00:00     ^C


Exiting on user cancel
Comment 5 seth vidal 2009-05-11 12:11:07 EDT
Which version of yum is this?
Comment 6 Gerry Reno 2009-05-11 12:18:27 EDT
# yum --version
3.2.14
# rpm -q yum
yum-3.2.14-10.fc9.noarch
Comment 7 seth vidal 2009-05-11 12:22:58 EDT
okay, I know what happened here.

f9 updates were pushed out with sha256 checksums in the repodata.

yum that shipped with f9 cannot handle these checksums.

This is being corrected on the updates master today.
Comment 8 Gerry Reno 2009-05-11 13:03:37 EDT
Thanks.  I knew there had to be something wrong somewhere.  It just wasn't acting like it used to.

Note You need to log in before you can comment on or make changes to this bug.