Bug 500079 - SMART value "Reallocated Sector Count" erroneously reported as failing
Summary: SMART value "Reallocated Sector Count" erroneously reported as failing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libatasmart
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-05-10 18:37 UTC by Sam
Modified: 2009-08-23 18:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-10 19:04:21 UTC


Attachments (Terms of Use)
Output of smartctl for the disk (4.16 KB, text/plain)
2009-05-10 18:37 UTC, Sam
no flags Details
Palimpsest overview screen for the disk (91.78 KB, image/png)
2009-05-10 18:39 UTC, Sam
no flags Details
Palimpsest SMART details for the disk (38.32 KB, image/png)
2009-05-10 18:41 UTC, Sam
no flags Details

Description Sam 2009-05-10 18:37:56 UTC
Created attachment 343283 [details]
Output of smartctl for the disk

Description of problem: Every time I log into my Fedora 11 Preview install, a warning pops up that a disk is failing. If I open Palimpsest and view the SMART details for the disk, the only failing attribute is "Reallocated Sector Count". The current and worst values are 199, while the threshold is 140. My understanding of SMART is that something is failing only if the values are lower than the threshold, so my disk shouldn't be reported as failing.


Version-Release number of selected component (if applicable):
gnome-disk-utility-0.3-1.fc11.i586
DeviceKit-003-1.i586
DeviceKit-disks-004-2.fc11.i586

How reproducible: Every time I log in.


Steps to Reproduce:
1. Log into GNOME.
2. "Disk is failing" dialog appears.

Actual results:
Disk reported as failing.

Expected results:
Disk not reported as failing.

Additional info:
The disk as a WDC WD800BB-00CAA1.

I'll attach screenshots of Palimpsest and the output of smartctl -a /dev/sda, which doesn't report the disk as failing.

Comment 1 Sam 2009-05-10 18:39:57 UTC
Created attachment 343284 [details]
Palimpsest overview screen for the disk

Comment 2 Sam 2009-05-10 18:41:08 UTC
Created attachment 343285 [details]
Palimpsest SMART details for the disk

Comment 3 David Zeuthen 2009-05-10 19:04:21 UTC
From what I can tell your disk has bad sectors and that's exactly why we report it as failing. It's supposed to work this way. If this was my disk, I'd back up the data and move it to a more healthy disk.

Moving to libatasmart and closing as NOTABUG since it's supposed to work this way.

Btw, Palimpsest is not using smartctl - it is (indirectly) using libatasmart which is more picky than smartctl is - e.g. just a single bad sector will trigger this warning.

Comment 4 David Zeuthen 2009-05-10 19:05:12 UTC
Comment on attachment 343283 [details]
Output of smartctl for the disk

(application/octet-stream isn't really a suitable mime type - text/plain is much better)

Comment 5 Sam 2009-05-11 22:34:26 UTC
Alright. Thanks for taking a look at this!


Note You need to log in before you can comment on or make changes to this bug.