Bug 500080 - Unabel to install git-arch on F-10
Unabel to install git-arch on F-10
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
10
All Linux
high Severity medium
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 15:01 EDT by Jochen Schmitt
Modified: 2013-01-10 05:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-17 14:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2009-05-10 15:01:36 EDT
When I try to install git-arch, I will get the following error messages:

export LANG="C"; sudo yum install git-arch
Configuration file /etc/yum/pluginconf.d/remove-stuff-plugin.conf not found
Unable to find configuration file for plugin remove-stuff-plugin
Loaded plugins: allowdowngrade, changelog, downloadonly, fastestmirror, fedorakmod, kernel-module, priorities, protectbase, refresh-packagekit, tsflags, versionlock
Loading mirror speeds from cached hostfile
 * rpmfusion-nonfree-updates: ftp-stud.hs-esslingen.de
 * rpmfusion-free-updates: ftp-stud.hs-esslingen.de
 * rpmfusion-free: ftp-stud.hs-esslingen.de
 * rpmfusion-nonfree: ftp-stud.hs-esslingen.de
 * non-free: mirror.yandex.ru
 * updates: ftp-stud.hs-esslingen.de
Reading version lock configuration
0 packages excluded due to repository protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package git-arch.x86_64 0:1.6.0.6-3.fc10 set to be updated
--> Processing Dependency: git = 1.6.0.6-3.fc10 for package: git-arch
--> Finished Dependency Resolution
git-arch-1.6.0.6-3.fc10.x86_64 from updates has depsolving problems
  --> Missing Dependency: git = 1.6.0.6-3.fc10 is needed by package git-arch-1.6.0.6-3.fc10.x86_64 (updates)
Error: Missing Dependency: git = 1.6.0.6-3.fc10 is needed by package git-arch-1.6.0.6-3.fc10.x86_64 (updates)
Comment 1 Todd Zullinger 2009-05-10 17:22:09 EDT
This works for me on a clean F10 x86_64 box.  It's possible that one of the yum plugins you have enabled is causing the problem, or perhaps there's an issue with a stale mirror?

Try disabling all yum plugins and see if that helps¹.  If so, enable them one at a time to determine which is the cause.  If I had to guess, I'd be most suspicious of the protectbase or versionlock plugins.

¹ yum --noplugins install git-arch

Note You need to log in before you can comment on or make changes to this bug.