Bug 500089 - libvirtd kills unrelated VM upon VM save
libvirtd kills unrelated VM upon VM save
Status: CLOSED DUPLICATE of bug 500158
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.4
All Linux
low Severity urgent
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 17:25 EDT by Matthew Farrellee
Modified: 2009-12-14 16:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 08:48:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Farrellee 2009-05-10 17:25:06 EDT
Description of problem:

# virsh create test-0.xml 
Domain test-0-RHEL5 created from test-0.xml

# virsh create test-1.xml 
Domain test-1-RHEL5 created from test-1.xml

# virsh list --all
 Id Name                 State
----------------------------------
  9 test-0-RHEL5         running
 10 test-1-RHEL5         running

# virsh save test-0-RHEL5 /tmp/libvirt-lose-bug/test-0.ckpt
Domain test-0-RHEL5 saved to /tmp/libvirt-lose-bug/test-0.ckpt

# virsh list --all
 Id Name                 State
----------------------------------

# virsh restore /tmp/libvirt-lose-bug/test-0.ckpt
Domain restored from /tmp/libvirt-lose-bug/test-0.ckpt

# virsh list --all
 Id Name                 State
----------------------------------
 11 test-0-RHEL5         running


Version-Release number of selected component (if applicable):

libvirt-0.6.2-1.el5


How reproducible:

Highly
Comment 1 Daniel Berrange 2009-05-11 05:57:35 EDT
This isn't a bug. virsh create  starts a transient guest which, by definition, disappear after they stop running. If you want it to still be visible after it shuts down, then use 'virsh define' followed by 'virsh start' to create  a persistent guest.
Comment 2 Matthew Farrellee 2009-05-11 08:38:06 EDT
The VM images here should never stop running without intervention. The act of saving one is stopping the other.

Were you not able to reproduce?
Comment 3 Daniel Berrange 2009-05-11 08:48:24 EDT
Oh, the bug subject is misleading.
Comment 4 Daniel Berrange 2009-05-11 08:48:48 EDT

*** This bug has been marked as a duplicate of bug 499698 ***
Comment 5 Daniel Berrange 2009-05-11 09:09:31 EDT

*** This bug has been marked as a duplicate of bug 500158 ***

Note You need to log in before you can comment on or make changes to this bug.