Bug 500091 - Anaconda crashes when I tried install using free space
Anaconda crashes when I tried install using free space
Status: CLOSED DUPLICATE of bug 495433
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:df0a9a5dd3088125e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 17:41 EDT by Vicente Ruiz
Modified: 2010-09-27 09:52 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-10 19:24:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (539.52 KB, text/plain)
2009-05-10 17:42 EDT, Vicente Ruiz
no flags Details
Attached traceback automatically from anaconda. (229.63 KB, text/plain)
2009-06-01 06:29 EDT, Jeffrey R. Evans
no flags Details
Attached traceback automatically from anaconda. (178.52 KB, text/plain)
2009-06-11 17:07 EDT, Michael G F Thomas
no flags Details
Attached traceback automatically from anaconda. (94.52 KB, text/plain)
2009-06-14 10:38 EDT, kens07
no flags Details
Attached traceback automatically from anaconda. (94.93 KB, text/plain)
2009-06-15 08:28 EDT, Vance
no flags Details
Attached traceback automatically from anaconda. (46.86 KB, text/plain)
2009-06-17 01:18 EDT, esdumbo2003
no flags Details
Attached traceback automatically from anaconda. (137.42 KB, text/plain)
2009-06-22 01:47 EDT, norbert
no flags Details
Attached traceback automatically from anaconda. (136.98 KB, text/plain)
2009-06-25 08:02 EDT, Wilko Quak
no flags Details
Attached traceback automatically from anaconda. (137.33 KB, text/plain)
2009-06-28 15:27 EDT, Wilko Quak
no flags Details
Attached traceback automatically from anaconda. (120.40 KB, text/plain)
2009-07-01 07:54 EDT, Jeffrey R. Evans
no flags Details
Attached traceback automatically from anaconda. (110.54 KB, text/plain)
2009-07-11 08:58 EDT, Mike Chambers
no flags Details
Attached traceback automatically from anaconda. (109.30 KB, text/plain)
2009-07-12 01:28 EDT, Mark Dixon
no flags Details
Attached traceback automatically from anaconda. (93.48 KB, text/plain)
2009-07-19 08:45 EDT, Need Real Name
no flags Details
Attached traceback automatically from anaconda. (220.68 KB, text/plain)
2009-08-09 19:52 EDT, Dale Reagan
no flags Details
Attached traceback automatically from anaconda. (134.32 KB, text/plain)
2009-09-21 10:48 EDT, Peter Larsen
no flags Details
Attached traceback automatically from anaconda. (75.12 KB, text/plain)
2009-10-01 20:40 EDT, ralacula
no flags Details
Attached traceback automatically from anaconda. (86.95 KB, text/plain)
2009-10-09 02:37 EDT, Harald H.
no flags Details
Attached traceback automatically from anaconda. (353.58 KB, text/plain)
2009-10-11 00:45 EDT, kmchowx
no flags Details
Attached traceback automatically from anaconda. (111.43 KB, text/plain)
2010-09-27 09:52 EDT, sumedh
no flags Details

  None (edit)
Description Vicente Ruiz 2009-05-10 17:41:20 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/geometry.py", line 128, in intersect
    return Geometry(PedGeometry=self.__geometry.intersect(b.getPedGeometry()))
  File "/usr/lib/anaconda/storage/partitioning.py", line 488, in getBestFreeSpaceRegion
    free_geom = extended.geometry.intersect(_range)
  File "/usr/lib/anaconda/storage/partitioning.py", line 705, in allocatePartitions
    boot=_part.req_bootable)
  File "/usr/lib/anaconda/storage/partitioning.py", line 566, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/storage/partitioning.py", line 187, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1330, in nextClicked
    self.anaconda.dispatch.gotoNext()
CreateException: Error al abrir /dev/sdc: No se ha encontrado el medio
Comment 1 Vicente Ruiz 2009-05-10 17:42:17 EDT
Created attachment 343303 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-05-10 19:24:09 EDT

*** This bug has been marked as a duplicate of bug 495433 ***
Comment 3 Jeffrey R. Evans 2009-06-01 06:29:01 EDT
Created attachment 346071 [details]
Attached traceback automatically from anaconda.
Comment 4 Michael G F Thomas 2009-06-11 17:07:10 EDT
Created attachment 347475 [details]
Attached traceback automatically from anaconda.
Comment 5 kens07 2009-06-14 10:38:35 EDT
Created attachment 347823 [details]
Attached traceback automatically from anaconda.
Comment 6 Vance 2009-06-15 08:28:23 EDT
Created attachment 347925 [details]
Attached traceback automatically from anaconda.
Comment 7 esdumbo2003 2009-06-17 01:18:01 EDT
Created attachment 348210 [details]
Attached traceback automatically from anaconda.
Comment 8 norbert 2009-06-22 01:47:16 EDT
Created attachment 348856 [details]
Attached traceback automatically from anaconda.
Comment 9 esdumbo2003 2009-06-22 16:00:21 EDT
Now I can installa Fedora 11, but to bypass this error, first I disabled in the BIOS the USB storage devices (for memory cards), in fact I disabled all the USB devices. There isn't any problem to install Fedora after that. 
Once the installation ended, reset the PC and I went to the bios to enabled the USB devices. When fedora loaded, automatically recognize the USB devices.
Comment 10 Wilko Quak 2009-06-25 08:02:17 EDT
Created attachment 349384 [details]
Attached traceback automatically from anaconda.
Comment 11 Wilko Quak 2009-06-28 15:27:22 EDT
Created attachment 349709 [details]
Attached traceback automatically from anaconda.
Comment 12 kens07 2009-06-28 17:30:37 EDT
(In reply to comment #9)

I was also able to install after unplugging my internal memory card reader. Then plugging it back in after the install was finished.
Comment 13 Jeffrey R. Evans 2009-07-01 07:54:05 EDT
Created attachment 350097 [details]
Attached traceback automatically from anaconda.
Comment 14 Mike Chambers 2009-07-11 08:58:43 EDT
Created attachment 351341 [details]
Attached traceback automatically from anaconda.
Comment 15 Mark Dixon 2009-07-12 01:28:43 EDT
Created attachment 351371 [details]
Attached traceback automatically from anaconda.
Comment 16 Need Real Name 2009-07-19 08:45:48 EDT
Created attachment 354274 [details]
Attached traceback automatically from anaconda.
Comment 17 Dale Reagan 2009-08-09 19:52:18 EDT
Created attachment 356827 [details]
Attached traceback automatically from anaconda.
Comment 18 Dale Reagan 2009-08-09 20:23:36 EDT
Comment on attachment 356827 [details]
Attached traceback automatically from anaconda.

After reading comments I disabled ALL USB and was able to get past the problem with TEXT mode install;  I tried GUI - it also worked without USB - but no mouse...
Comment 19 Peter Larsen 2009-09-21 10:48:48 EDT
Created attachment 361954 [details]
Attached traceback automatically from anaconda.
Comment 20 ralacula 2009-10-01 20:40:57 EDT
Created attachment 363408 [details]
Attached traceback automatically from anaconda.
Comment 21 Harald H. 2009-10-09 02:37:03 EDT
Created attachment 364205 [details]
Attached traceback automatically from anaconda.
Comment 22 Harald H. 2009-10-09 03:39:01 EDT
I was unable to deactivate usb (sometimes BIOS is somehow annoying if everything is locked ...). It is a medion-computer (sold by aldi/hofer germany/austria, perhaps on some other location too). The main point for me was, I didn't have to disable usb, but the built in cardreader (using an usb-port) was th problem, I just detached it and installed fedora without problem. Thanks to other users here for the info with the usb ...
Comment 23 kmchowx 2009-10-11 00:45:21 EDT
Created attachment 364358 [details]
Attached traceback automatically from anaconda.
Comment 24 sumedh 2010-09-27 09:52:22 EDT
Created attachment 449898 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.