Bug 500124 - Upgrade of version 2.3 rel 7 breaks existing installation due to new dependencies
Upgrade of version 2.3 rel 7 breaks existing installation due to new dependen...
Status: CLOSED DUPLICATE of bug 498334
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 06:04 EDT by Bevis King
Modified: 2009-05-11 08:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 08:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bevis King 2009-05-11 06:04:57 EDT
Description of problem:
When you install the latest upgrade of gallery2 - 2.3 release 7 - it breaks existing installations due to the absence of /usr/share/gallery2/lib/smarty/Smarty.class.php .

The error after the upgrade has been performed is:
[Mon May 11 10:58:33 2009] [error] [client 131.227.95.112] PHP Fatal error:  Gal
leryCoreApi::require_once() [<a href='function.require'>function.require</a>]: F
ailed opening required '/usr/share/gallery2/modules/core/classes/../../../lib/sm
arty/Smarty.class.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr
/share/gallery2/modules/core/classes/GalleryCoreApi.class on line 2827

Version-Release number of selected component (if applicable):
gallery2-2.3-7.fc10.noarch

How reproducible:
Done once, installation now unserviceable.

Steps to Reproduce:
1.  yum upgrade gallery2
  
Actual results:
Upgrade rpms get installed, upgrade procedure run as directed, gallery2 no longer works.

Expected results:
Upgrade takes place and new version works normally.

Additional info:
Comment 1 Bevis King 2009-05-11 06:11:20 EDT
OK - here's a fix:

1. Make gallery 2.3 depend upon php-Smarty

2. Add a symlink in /usr/share/gallery2/lib as follows:

      ln -s /usr/share/php/Smarty/ smarty

That seems to have restored access to the gallery2 installation.

Regards, Bevis.
Comment 2 Gwyn Ciesla 2009-05-11 08:18:35 EDT

*** This bug has been marked as a duplicate of bug 498334 ***

Note You need to log in before you can comment on or make changes to this bug.