Bug 500137 - post-receive-mail script should be moved to a better location
post-receive-mail script should be moved to a better location
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: git (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
ActualBug
:
Depends On: 600411
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 07:22 EDT by Noa Resare
Modified: 2013-01-10 05:32 EST (History)
5 users (show)

See Also:
Fixed In Version: git-1.7.4.1-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-09 13:26:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noa Resare 2009-05-11 07:22:26 EDT
Description of problem:
The git distribution contains a script that can be used to send emails when
a new revision is pushed onto a repository named post-receive-email

This script currently resides in the documentation directory of git, a location
that has the version name of the git package encoded into it. This is a bit inconvenient since it will lead to silent breakage of the email hook on existing repositories when the git package is updated if the method of invoking the script suggested in the post-receive hook template script is used.

Version-Release number of selected component (if applicable):
git-1.5.5.6-2.el5

I would suggest moving the hooks directory from %doc/hooks to /usr/share/git-core and at the same time update the post-receive hook template to refer to the new location in it's last line.
Comment 1 Todd Zullinger 2009-06-28 19:31:50 EDT
I've committed a change like this to the rawhide packages.  I'll try to see that it makes its way into the EL-5 branch at some point.

FWIW, the spec file from rawhide should rebuild on EL-5, if you wanted to test it and have an updated git. :)
Comment 2 Todd Zullinger 2010-06-11 12:37:35 EDT
Discussed an update to git-1.7.x on epel-devel-list yesterday.  Any help testing the packages there would be great.

http://www.redhat.com/archives/epel-devel-list/2010-June/msg00023.html
Comment 3 Fedora Update System 2011-02-16 13:56:35 EST
git-1.7.4.1-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/git-1.7.4.1-1.el5
Comment 4 Fedora Update System 2011-02-16 16:39:19 EST
git-1.7.4.1-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update git'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/git-1.7.4.1-1.el5
Comment 5 Fedora Update System 2011-03-09 13:26:28 EST
git-1.7.4.1-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.