Bug 500143 - httpd dead but subsys locked - httpd will not start on fedora 11 beta.
Summary: httpd dead but subsys locked - httpd will not start on fedora 11 beta.
Keywords:
Status: CLOSED DUPLICATE of bug 501123
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: rawhide
Hardware: i386
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-05-11 12:00 UTC by the.hw.group
Modified: 2009-05-16 22:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-16 22:19:59 UTC
Type: ---


Attachments (Terms of Use)
sos report (fedora 11 i386 beta) (1.13 MB, application/x-bzip2)
2009-05-11 12:34 UTC, the.hw.group
no flags Details
here is the strace of httpd (I named it "file") bzipped (10.59 KB, application/x-bzip2)
2009-05-11 16:24 UTC, the.hw.group
no flags Details

Description the.hw.group 2009-05-11 12:00:36 UTC
Description of problem:
httpd service will not start. (httpd dead but subsys locked)

[root@fail ~]# service httpd start
Starting httpd:                                            [  OK  ]
[root@fail ~]# service httpd status
httpd dead but subsys locked

[root@fail ~]# rpm -q httpd
httpd-2.2.11-8.i586



Version-Release number of selected component (if applicable):

[root@fail ~]# rpm -q httpd
httpd-2.2.11-8.i586

How reproducible:

install fedora 11 beta, update the system to current patches in rawhide. then run "service httpd start" and "service httpd status"

  
Actual results:


Expected results:

expected result is for the service to start

Additional info:

Comment 1 the.hw.group 2009-05-11 12:34:14 UTC
Created attachment 343439 [details]
sos report (fedora 11 i386 beta)

attaching sosreport of my system. (fedora 11 i386 beta) Please let me know what you all need to resolve this.

Comment 2 the.hw.group 2009-05-11 15:14:04 UTC
I have disabled selinux (just as a precaution) and have deleted the pidfile / lockfile for httpd, still the same result. This is very strange, and I di not know how to troubleshoot.

Also, I have removed a few modules / conf files that are optional for httpd as a 2nd precaution. Same result.

Comment 3 the.hw.group 2009-05-11 16:24:10 UTC
Created attachment 343478 [details]
here is the strace of httpd (I named it "file") bzipped

here is the strace of httpd (I named it "file") bzipped, perhaps this can help with the troubleshooting process.

Comment 4 Joe Orton 2009-05-11 19:42:07 UTC
Try 

"yum erase mod_*"

and see if httpd itself works.  ISTR one of the random third-party modules was breaking like this.

Comment 5 Quentin Armitage 2009-05-16 16:58:39 UTC
The directory /etc/httpd/run/mod_fcgid is missing.

As root, mkdir /etc/httpd/run/mod_fcgid and then try service httpd start. This solved the problem for me.

Comment 6 Quentin Armitage 2009-05-16 17:32:41 UTC
Reported as bug #501123 for mod_fcgid

Comment 7 Paul Howarth 2009-05-16 20:08:06 UTC
What's the output of "rpm -V httpd"?

I suspect you've lost the symlink /etc/httpd/run -> ../../var/run

Comment 8 Quentin Armitage 2009-05-16 20:42:51 UTC
[root@samson httpd]# rpm -V httpd
S.5....T.  c /etc/httpd/conf/httpd.conf

As comment #2 in #501123, I have the symlink /etc/httpd/run -> ../../var/run/http

Comment 9 Quentin Armitage 2009-05-16 20:45:12 UTC
Correction to comment #8, symlink should have stated:
/etc/httpd/run -> ../../var/run/httpd

Comment 10 Joe Orton 2009-05-16 22:19:59 UTC
Right - that directory moved.  Closing as dupe.  (Sorry Paul, didn't expect this would hit any third-party modules, otherwise I'd have given a wider heads-up)

*** This bug has been marked as a duplicate of bug 501123 ***


Note You need to log in before you can comment on or make changes to this bug.