This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 500185 - Segfault while running Fedora 11 Preview guest
Segfault while running Fedora 11 Preview guest
Status: CLOSED DUPLICATE of bug 497170
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 11:03 EDT by Frank Arnold
Modified: 2009-05-11 13:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 13:41:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
GDB backtrace (5.05 KB, text/plain)
2009-05-11 11:03 EDT, Frank Arnold
no flags Details

  None (edit)
Description Frank Arnold 2009-05-11 11:03:08 EDT
Created attachment 343465 [details]
GDB backtrace

Description of problem:
I get a segfault while running a 32-bit non-PAE Fedora 11 Preview guest on a Fedora 11 Preview host. The guest is running CTCS stress test. I was able to reproduce it 3 times. It takes about 2 hours until the guest process dies.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-102.fc11.x86_64
qemu-common-0.10-16.fc11.x86_64
qemu-debuginfo-0.10-16.fc11.x86_64
qemu-kvm-0.10-16.fc11.x86_64
qemu-kvm-tools-0.10-16.fc11.x86_64
qemu-system-x86-0.10-16.fc11.x86_64

Guest flags:
-name 002-CTCS -k de -monitor pty -vnc :1 -usbdevice tablet -m 1280 -smp 3 -hda /xen/images/fedora_11_preview_32b_qcow.img -hdb /xen/images/002.img -serial file:/tmp/guest2.fifo -net nic,model=e1000 -net tap,ifname=tap1

How reproducible:
Takes about 2 hours to reproduce.

Additional info:
Just an unqualified guess, but it's probably this issue...
http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commit;h=7403b14eeb4670d54497284b110ca3e3be4a99a4
Comment 1 Mark McLoughlin 2009-05-11 13:41:14 EDT
Thanks Frank, this is a dup of bug #497170

We'll either cherry-pick the fix into a qemu update soon, or if upstream releases 0.10.3 we'll jump to that

*** This bug has been marked as a duplicate of bug 497170 ***

Note You need to log in before you can comment on or make changes to this bug.