Bug 500196 - sporadic "mount: unknown filesystem type: 'jffs2'" at boot
sporadic "mount: unknown filesystem type: 'jffs2'" at boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2009-05-11 12:00 EDT by Chris Ball
Modified: 2010-06-28 08:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ball 2009-05-11 12:00:28 EDT
(Wasn't sure which component to use, sorry.)

Description of problem:

Most (but not all) of the time, boot fails on the XO with "mount: unknown filesystem type: 'jffs2'".  This is a recent regression, since the beta.

Version-Release number of selected component (if applicable):

Rawhide XO, 20090510.

How reproducible:

Sporadically.

Additional info:

I wouldn't have thought this was possible.  mount(8) only displays this error if the filesystem type is not present in /proc/filesystems.  The fact that this works on some boots suggests a race between jffs2 appearing there and the mount call being made.  jffs2.ko is obviously present on disk, since other attempts at boot succeed.

(We use a modified live.py to add jffs2 into the initrd.)
Comment 1 Chris Ball 2009-05-11 13:18:37 EDT
If I get the initrd to dump me to a shell after mounting root fails, I *do* see jffs2 in /proc/filesystems, and the mount works manually at this point.

So this is either an odd race, or the claim that the only way to get here is by having jffs2 be absent from /proc/filesystems is wrong.
Comment 2 Mikus Grinbergs 2009-05-11 14:31:43 EDT
I don't know if this is related to the subject of bug #500196, but for me, on a machine on which a previous boot process stalled with the message "mount: unknown filesystem type: 'jffs2'" showing, a subsequent boot process sometimes stalls slightly earlier, with the message "Loading ramdisk image from nand:\boot\initrd0.img ... " still showing (and nothing further happening). 


--------

When either of these boot_process_stalls keeps repeating, my "bypass" is to unplug some of the external USB devices I normally have plugged into my XO, then reboot.  That appears to change some sort of internal timing, with the result that often (but not always) the boot process then does not stall.

If I am unable to get past the boot_process_stall, I re-flash all of nand (typically with a non-rawhide build).  That lets me again use the XO, starting with a "clean slate".
Comment 3 Chris Ball 2009-05-11 14:39:55 EDT
(In reply to comment #2)
> I don't know if this is related to the subject of bug #500196

No, I can't imagine that it could be.
Comment 4 Mikus Grinbergs 2009-05-11 14:45:29 EDT
Note:  I have seen the "mount: unknown filesystem type: 'jffs2'" error when booting rawhide-xo build 20090416 on an XO.  I have not seen that error when booting 8.2.x builds on an XO.
Comment 5 Chris Ball 2009-05-11 16:45:18 EDT
Tried rootdelay=2, doesn't help.
Comment 6 Chris Ball 2009-05-11 19:17:47 EDT
After updating to today's image, the mount is failing every time.
Comment 7 Mikus Grinbergs 2009-05-11 20:17:02 EDT
(In reply to comment #6)
> After updating to today's image, the mount is failing every time. 

I updated to rawhide-xo 20090511.img (installed via 'copy-nand').
Never ever saw the mount to fail.

Just to be sure, I've added "rootdelay=300" in file /boot/olpc.fth
Comment 8 Peter Robinson 2009-05-12 02:08:58 EDT
(In reply to comment #5)
> Tried rootdelay=2, doesn't help.  

Can you try rootdelay=300 or 500. I think the timing is in ms not sec.
Comment 9 Chris Ball 2009-05-12 13:38:49 EDT
It's in seconds:

    if (root_delay) {
        printk(KERN_INFO "Waiting %dsec before mounting root device...\n", root_delay);
        ssleep(root_delay);
    }

I think rootdelay might not help, because I'm guessing that we only modprobe jffs2 at the moment we try to perform the mount, not before -- we actually want a delay *while* mounting root, inbetween modprobing jffs2 and when mount checks to see whether it's present in /proc/filesystems.  It shouldn't be possible (on UP) to beat the module init in userspace, but it certainly seems like that's what's happening.
Comment 10 Bug Zapper 2009-06-09 11:38:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2010-04-27 10:16:18 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2010-06-28 08:29:27 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.